Gentoo Archives: gentoo-dev

From: hasufell <hasufell@g.o>
To: gentoo-dev@l.g.o, Matthias Maier <tamiko@g.o>
Subject: [gentoo-dev] Re: [gentoo-commits] repo/gentoo:master commit in: app-emulation/libvirt/
Date: Sun, 04 Oct 2015 09:45:44
Message-Id: 5610F53C.8040904@gentoo.org
1 On 10/03/2015 08:29 PM, Matthias Maier wrote:
2 > commit: a1015c1339068e9e942cb353f46a015b5612db1e
3 > Author: Matthias Maier <tamiko <AT> gentoo <DOT> org>
4 > AuthorDate: Sat Oct 3 18:26:45 2015 +0000
5 > Commit: Matthias Maier <tamiko <AT> gentoo <DOT> org>
6 > CommitDate: Sat Oct 3 18:29:30 2015 +0000
7 > URL: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a1015c13
8 >
9 > app-emulation/libvirt: version bump to 1.2.20
10 >
11 > Package-Manager: portage-2.2.22
12 >
13 > app-emulation/libvirt/Manifest | 1 +
14 > app-emulation/libvirt/libvirt-1.2.20.ebuild | 492 ++++++++++++++++++++++++++++
15 > 2 files changed, 493 insertions(+)
16 >
17 > diff --git a/app-emulation/libvirt/Manifest b/app-emulation/libvirt/Manifest
18 > index 816bdef..961bf34 100644
19 > --- a/app-emulation/libvirt/Manifest
20 > +++ b/app-emulation/libvirt/Manifest
21
22 [...]
23 > +
24 > + [[ -n ${BACKPORTS} ]] && \
25 > + EPATCH_FORCE=yes EPATCH_SUFFIX="patch" \
26 > + EPATCH_SOURCE="${WORKDIR}/patches" epatch
27 > +
28
29 little bash nitpicking... the '\' after '&&' is obsolete syntax
30
31 [...]
32 > +
33 > + # Tweak the init script
34 > + local avahi_init=
35 > + local iscsi_init=
36 > + local rbd_init=
37 > + local firewalld_init=
38 > + cp "${FILESDIR}/libvirtd.init-r15" "${S}/libvirtd.init"
39
40 missing || die
41
42 [...]
43 > + sed -e "s/USE_FLAG_FIREWALLD/${firewalld_init}/" -i "${S}/libvirtd.init"
44 > + sed -e "s/USE_FLAG_AVAHI/${avahi_init}/" -i "${S}/libvirtd.init"
45 > + sed -e "s/USE_FLAG_ISCSI/${iscsi_init}/" -i "${S}/libvirtd.init"
46 > + sed -e "s/USE_FLAG_RBD/${rbd_init}/" -i "${S}/libvirtd.init"
47
48 missing || die on all seds
49
50
51 > +
52 > + ## additional host drivers
53 > + myconf+=" $(use_with apparmor)"
54 > + myconf+=" $(use_with apparmor apparmor-profiles)"
55 > + myconf+=" $(use_with virt-network network)"
56 > + myconf+=" --with-storage-fs"
57 > + myconf+=" $(use_with lvm storage-lvm)"
58 > + myconf+=" $(use_with iscsi storage-iscsi)"
59 > + myconf+=" $(use_with parted storage-disk)"
60 > + mycond+=" $(use_with glusterfs)"
61 > + mycond+=" $(use_with glusterfs storage-gluster)"
62 > + myconf+=" $(use_with lvm storage-mpath)"
63 > + myconf+=" $(use_with rbd storage-rbd)"
64 > + myconf+=" $(use_with numa numactl)"
65 > + myconf+=" $(use_with numa numad)"
66 > + myconf+=" $(use_with selinux)"
67 > + myconf+=" $(use_with fuse)"
68
69 All this myconf stuff is very difficult to read, why not use a bash array?
70
71 In addition, it has two spelling errors "mycond", so gluterfs USE flag
72 is currently broken. Another reason to not use this form.