Gentoo Archives: gentoo-dev

From: Mike Gilbert <floppym@g.o>
To: Gentoo Dev <gentoo-dev@l.g.o>
Subject: Re: [gentoo-dev] chromium-54 needs ffmpeg-3.0.1
Date: Mon, 29 Aug 2016 03:16:14
Message-Id: CAJ0EP42PBZOm9eW2=4N5ha3CvOi1XtLEpdfmjgCYJ8+ep56LPg@mail.gmail.com
In Reply to: Re: [gentoo-dev] chromium-54 needs ffmpeg-3.0.1 by Kristian Fiskerstrand
1 On Sun, Aug 28, 2016 at 3:57 PM, Kristian Fiskerstrand <k_f@g.o> wrote:
2 > On 08/28/2016 07:28 PM, PaweĊ‚ Hajdan, Jr. wrote:
3 >> B. Backport just the changes needed for chromium to older ffmpeg
4 >
5 > Any chance of it being included upstream or would it be a downstream
6 > carry for a long time?
7
8 I haven't looked at any code, but given that it's a major version bump
9 of a library, the changes probably involve API-breaks. Backporting
10 them upstream or downstream is probably not a simple matter, and
11 probably a bad idea.
12
13 >>
14 >> C. Mask chromium's system-ffmpeg flag when the dependency on
15 >> ffmpeg-3.0.1 can't be satisfied
16 >
17 > Would this result in using bundled libraries instead?
18
19 Yes, masking the system-ffmpeg USE flag would cause the bundled ffmpeg
20 code to be used.
21
22 The Chromium project applies security fixes quite regularly, so don't
23 get too worried over it.

Replies

Subject Author
Re: [gentoo-dev] chromium-54 needs ffmpeg-3.0.1 Jason Zaman <perfinion@g.o>