Gentoo Archives: gentoo-dev

From: Arfrever Frehtes Taifersar Arahesis <Arfrever@g.o>
To: Gentoo Development <gentoo-dev@l.g.o>
Subject: Re: [gentoo-dev] Minor changes in python.eclass and distutils.eclass
Date: Wed, 14 Jul 2010 22:36:48
In Reply to: Re: [gentoo-dev] Minor changes in python.eclass and distutils.eclass by Mike Frysinger
2010-07-06 01:37:01 Mike Frysinger napisaƂ(a):
> On Monday, July 05, 2010 19:31:59 Arfrever Frehtes Taifersar Arahesis wrote: > > Only 84 ebuilds in the tree set NEED_PYTHON variable. NEED_PYTHON can be > > used only in EAPI <=2. python_pkg_setup() is optional in EAPI <=3. Exactly > > 0 ebuilds, which use NEED_PYTHON, also call python_pkg_setup(). > > EXPORT_FUNCTIONS wasn't ommitted during this calculation. > > well then, it shouldnt be hard for you to fix that small number and drop this > crap from the tree. > > your global scope echo still doesnt require color support. everyone is > telling you for obvious reasons to stop doing this. so do it already.
NEED_PYTHON has been removed from all ebuilds in gentoo-x86, so now there shouldn't be any problems with printing this deprecation warning in global scope. -- Arfrever Frehtes Taifersar Arahesis


File name MIME type
signature.asc application/pgp-signature