Gentoo Archives: gentoo-java

From: Joshua Nichols <nichoj@g.o>
To: Wiktor Wandachowicz <siryes@×××××.com>
Cc: gentoo-java@l.g.o
Subject: Re: [gentoo-java] Re: problems compiling junit
Date: Wed, 12 Apr 2006 13:24:46
In Reply to: [gentoo-java] Re: problems compiling junit by Wiktor Wandachowicz
Wiktor Wandachowicz wrote:
> Henrique Ferreiro <henrique.ferreiro@...> writes: > > >> BUILD FAILED >> java.lang.UnsupportedClassVersionError: junit/framework/Test >> (Unsupported major.minor version 49.0) >> >> > > OTOH after some thought, this error simply means that while currently > you have 1.4 system JVM, some libraries were compiled with 1.5 JVM. > This is unfortunate, because Java 1.4 cannot use 1.5 classes (their > internal file format is different). > > Maybe you should look into java-1.5-fixer, previously posted by Joshua > on the same list? ( > > It's also possible to rebuild the offending packages by hand, but you > will have to find them manually (it may take some time, though...) > The first step is to determine the packages that depends on Java and > then remerge them. I've done it once, so I know it's at least possible :) > > # emerge -avu gentoolkit ### If you don't have equery, that is > # equery depends virtual/jdk | tee ~/java-packages.txt | less > > HTH, > Wiktor > >
java-1.5-fixer actually is installed now to /usr/bin/java-1.5-fixer. As for the problem you're having, it says in the documentation that if you were using 1.5 as a system vm, you will need to run java-1.5-fixer in order to get your system in tip-top-shape. Unfortunately, the script isn't flawless, as I previously mentioned on the list [1]. In particular, if something that depends is used by ant is compiled with 1.5, the script will choke up on it. The workaround is to try to figure out what classes are still compiled with 1.5, unmerge them all, then remerge them. [1] - Josh -- gentoo-java@g.o mailing list