Gentoo Archives: gentoo-java

From: Joshua Nichols <nichoj@g.o>
To: gentoo-java@l.g.o
Subject: [gentoo-java] java-config-wrapper and (old) java-config blockage
Date: Fri, 14 Apr 2006 02:01:35
Just sending a heads up, but I will be making an update soon that will
make dev-java/java-config-wrapper be blocked by older versions of
dev-java/java-config. Specifically, this means < 1.3. If you're already
migrated, this shouldn't affect you. If you haven't migrated, this
shouldn't effect you. It really only effects people that are migrating,
in which case the documentation will be updated according.

The reason for this is as follows: <java-config-1.3 installs
/usr/bin/java-config. This is the actually java-config.

java-config-wrapper installs /usr/bin/java-config as well. This is a
wrapper, which will call /usr/bin/java-config-1 or
/usr/bin/java-config-2 as necessary.

This results in a file collision, so blocking is necessary.


gentoo-java@g.o mailing list