Gentoo Archives: gentoo-kernel

From: Sebastian Kromp <teufelpersoenlich@×××.de>
To: gentoo-kernel@l.g.o
Subject: Re: [gentoo-kernel] wacom bug question (bug #205261)
Date: Thu, 07 Feb 2008 19:59:26
Hash: SHA1

Daniel Drake schrieb:
> Sebastian Kromp wrote: >> I´ve choosed this bug for beginning >> , and after >> searching the web I´ve found this >> , and >> I think, that could solve the problem. But because I don´t want >> to do something wrong, I want to ask first, what I exactly should >> do now, cause it´s a little bit unclear for me. > > You've found a document detailing how to match up the kernel side > driver part (wacom) with the userspace configuration for the > tablet. > > The problem in this case is that the kernel driver is not > recognizing the device, and hence is not creating the > /dev/input/eventX interface that the document is talking about. So, > the document is not entirely relevant because the problem occurs > at a lower layer. > > The next thing to do on that bug is to research the issue. Try and > find other Linux users who have the same hardware, and see whether > they are reporting it as working or broken. If it appears broken > for everyone, has it been reported to the wacom developers, perhaps > on a mailing list? Are there any patches available? Google around a > bit, and let us know what you find (if you're confident you can > just put your findings directly on the bug). > > Also, you'll see that I asked for "lsusb -v" output. I asked for > this because all USB devices have unique ID numbers (vendor and > product ID) which can be useful when searching. In this case the > vendor ID is 056a and the product ID is 0090 (see if you can find > where I read those numbers from in his attachment). Just putting > the phrase "056a 0090" into google seems to bring up some relevant > results. > > Thanks, Daniel
I thought the linuxwacom-project offers a kernelmodule too, but they seem not to, sorry. Well, I´ve found this bug at the kernel bugzilla and looked for the vendor_id-struct at the /drivers/input/tablet/wacom_wac.c of the kernels, 2.6.23-gentoo-r3 (the bugreporter uses), 2.6.23-gentoo-r6 and 2.6.24-git16 and the Vendor ID 0x56a isn´t there. I´m not sure if it´s true, but I guess this means, that this tablet isn´t supported yet, isn´t it? I´ve searched for other reports too. I have found a "fix", which doesn´t work (, but it seems, that the guys are working for a fix at it, I will try to contact one of the guys to ask, if they maybe found something useful. I´ve found lots of reports , that says that this tablet isn´t working/supported yet, but the linux-wacom-project seems to work at it /( I've contacted Ping Cheng form Linux Wacom Tablet Project and asked when they will add support for us. Answer: "It is in my to-do list ). But, I don't have time to work on it soon. If you have development experience, you may work on it. Otherwise, we'll have to see if there is anyone else available in the development group before I get a chance to work on it. " - / / The tablet seems to work with the usbhid-module with older kernels under Ubuntu, but without sensitivity and the other tablet-special stuff. I have nothing found, that points to that this problem was reported to the wacom or kernel developers. I hope this all is useful, Sincerely, Sebastian / / -----BEGIN PGP SIGNATURE----- Version: GnuPG v2.0.7 (GNU/Linux) Comment: Using GnuPG with Mozilla - iQIVAwUBR6tjCbsPWF8MEmaqAQLiyhAA12mtC0QW8lVwcqDNb0kg2Ms553wnltdC oCoqMWNRL4iSpOfqPvPHUA8mopET2x/D2bUD0c2ARyD154GFGKVYZ89tP6kNIf97 KB8VvYiQkYLnNs8x19cKS9uomnahBUSThJ2JIc9xOxNIrfvItz5sL6znMkXRvm+F ii9dqRIFI6kiEIKTnNLY7nx1ftXeCxZMS6zB34d/0zdeT2+jZn6GJQR2wtawCN2N WZtrLdmEai6hep7jKUfuGflLCd7+Bz4BxjVW4gUsUZzgJEDr+qZpynWg8yJznhre 59FBHzQaDgfyOaZ0p8/9dbmhJXKp0qDy/sHe/1kjuirh1sqeV/cZjvZj+hNI8zB+ e9T/HVgDf5mh8lw6mC2ZAuhbBSh8Pc82gbmY82Rd5jqlcE4ZmnR/6xsenBt1wZSc C/+LbPu0RBuBKV38jkp3EjlfgHW20iYrQwmBcdB73PCqNCyWkSB7ayGKdIjzBVkl 3OIGPhohdb6jbSiQUlvldT4TiSHFoDuhp6Ym/S19RURQnIfN4JAiCg3jR8n8qrna 1BWXaf0EVivrlogOmDRCn8e9nv0iOA0wFS7r25u7IeL6ByYUNY1du0H3BiEJNl8H nWJrRbh2z0wIR9NDQhC6WWaAvL1grsjFbAh8LZTNTTah6XYtYg0gz8fjfmyta2fb aHiwoLEFhjY= =NTVU -----END PGP SIGNATURE----- -- gentoo-kernel@l.g.o mailing list


Subject Author
Re: [gentoo-kernel] wacom bug question (bug #205261) Daniel Drake <dsd@g.o>