Gentoo Archives: gentoo-laptop

From: Brian Bulkowski <brian@×××××××××.org>
To: gentoo-laptop@l.g.o
Subject: Re: [gentoo-laptop] D-Link DWL-650
Date: Wed, 15 Jun 2005 16:29:41
In Reply to: [gentoo-laptop] D-Link DWL-650 by Alex Laughlin-Dendy
D-Link changes chipssets among the same "version" of the card. I have a 
DWL-650G rev C, which is Atheros (although I'm running windows, I'm 
running Wireless capture software, which requires a special driver --- 
I'm using a NetGear with a known Atheros chipset in my Gentoo machine). 
I'm confused by which card you might have, unlikely it's the same as 
mine, but you'll have to dig to figure it out. Maybe just try a couple 
of things.

About masked packages - find the howto, use it. All the Atheros 
(MadWifi) projects are masked, too.


Alex Laughlin-Dendy wrote:

>Hi, > > I've got a D-Link DWL-650 PCMCIA wireless card and I'm trying to >make it work with gentoo and my Dell laptop. I'm competely clueless >here as I've never made wireless work on linux before. I've tried >using ndiswrapper and cardmgr to load the drivers, but ndiswrapper >won't see the hardware at all and cardmgr gives me these error >messages when I put the card in: > >Jun 14 11:08:57 [cardmgr] socket 0: D-Link DWL-650 >Jun 14 11:08:58 [kernel] hermes @ IO 0x280: Timeout waiting for card >to reset (reg=0x0000)! >Jun 14 11:08:59 [wait_for_sysfs] error: unknown bus, please report to ><linux-hotplug-devel@×××××××××××××××××.net> 'pcmcia' >Jun 14 11:08:59 [wait_for_sysfs] either wait_for_sysfs (udev 045) >needs an update to handle the device >'/devices/pci0000:00/0000:00:03.0/0.0' properly (unknown bus) or the >sysfs-support of your device's driver needs to be fixed, please report >to <linux-hotplug-devel@×××××××××××××××××.net> >Jun 14 11:08:59 [cardmgr] get dev info on socket 0 failed: Resource >temporarily unavailable > >I take it I'm not using the right driver. What driver should I be >using? Is there an easy way to make these cards work? > >Thanks. :-) > > >
-- gentoo-laptop@g.o mailing list


Subject Author
Re: [gentoo-laptop] D-Link DWL-650 Alex Laughlin-Dendy <aldendy@×××××.com>