Gentoo Archives: gentoo-osx

From: m h <sesquile@×××××.com>
To: gentoo-osx@l.g.o
Subject: Re: [gentoo-osx] [PREFIX] SUCCESS!!! system installed
Date: Thu, 23 Mar 2006 04:14:29
Message-Id: e36b84ee0603222014k715f96eepd517e70b0b7f493b@mail.gmail.com
In Reply to: Re: [gentoo-osx] [PREFIX] SUCCESS!!! system installed by Kito
On 3/23/06, Kito <kito@g.o> wrote:
> > On Mar 22, 2006, at 6:32 PM, m h wrote: > > > During a freak reversal of magnetic poles, the latest prefix code was > > able to emerge the base system! > > > > It involved doing everything previously mentioned in this week's > > spam thread. > > To get around the gcc issue, gcc3.3.6 was installed. > > Ok, so we'll bump the gcc versions in the prefix tree. I'd like to > 4.x in there anyway as well.
This was NOT a version bump. The version in the tree was 3.4.4...
> > > > > The next issue was complaints about "-fno-stack-protector" available > > on gcc. The was no gcc binary in $PREFIX, so I resolved this by > > adding a gcc symlink in $PREFIX to ${PREFIX}/usr/bin/gcc-3.3.6. > > This should be solved by using gcc-config, which sets the appropriate > symlinks. Its probably broken in prefix though, haven't tested it yet. >
Yeah, I didn't even try this....
> > > > I hit the missing libpython2.4.so issue again, so I added > > ${PREFIX}/usr/lib/ to LD_LIBRARY_PATH. > > Hmm, so Diego was right...this obviously needs to be fixed. did > running env-update work as expected?
Didn't try this either. Maybe tomorrow. (I'm not at the machine right now)
> > > > > That along with a few ebuild foo.ebuild digest, and manually > > downloading a few tarballs and putting them in distfiles allowed me to > > finish emerge -av system. > > Why the manual downloads?
Don't know but some of the tarballs weren't found in the default places. (I don't think it was an exhaustive search, but after I see 5 or so failed attempts I just google for "Index of" and the tarball name, and download it and put it in distfiles.
> > > > > Next task, get apache working. Stay tuned.... > > > > -matt > > > > ps - thanks a lot for your help grobian and kito! > > > > No problem at all, thanks for testing ;). Glad you finally got it > working, hopefully we can get the bootstrap script working well > enough to make this not as tedious/trial-and-error. >
I'm still interested in seeing this bootstrap script when it makes it's appearance. -matt -- gentoo-osx@g.o mailing list

Replies

Subject Author
Re: [gentoo-osx] [PREFIX] SUCCESS!!! system installed Grobian <grobian@g.o>