Gentoo Archives: gentoo-perl

From: Christian Hartmann <ian@g.o>
To: gentoo-perl@g.o
Subject: Re: [gentoo-perl] Proposed perl-module.eclass additions
Date: Wed, 09 Aug 2006 17:10:17
In Reply to: [gentoo-perl] Proposed perl-module.eclass additions by Michael Cummings
> I'd like to propose adding two new vars to the perl-module.eclass. (all > naming conventions completely open to change)
About the naming conventions I propose to add something in the beginning of the name of the function that shows which eclass the function belongs to, just like eutils does e.g. - So I'd vote for something like 'pm_echovar' (pm_ = perl-module) just to avoid naming collisions.
> echovar - if defined, used in src_prep for passing an answer to perl > Makefile.Pl|perl Build.PL. Could save some overhead with ebuilds that > need that extra input, letting us stick to the basic skeleton ebuild for > even *more* perl-modules :)
> patchlist - array of patches to be applied in src_unpack. Just a > thought, mostly along the same lines as above, cleaning up the skeletons > and putting more work in the eclass.
Sure.. why not. - Wouldn't that be something for eutils btw? -- Christian Hartmann PGP Key: Key fingerprint = 4544 EC0C BAE4 216F 5981 7F95 2154 E5EE 692A 4865 -- gentoo-perl@g.o mailing list


Subject Author
Re: [gentoo-perl] Proposed perl-module.eclass additions Michael Cummings <mcummings@g.o>
Re: [gentoo-perl] Proposed perl-module.eclass additions Michael Cummings <mcummings@g.o>