Gentoo Archives: gentoo-portage-dev

From: "Michał Górny" <mgorny@g.o>
To: gentoo-portage-dev@l.g.o
Cc: "Michał Górny" <mgorny@g.o>
Subject: [gentoo-portage-dev] [PATCH 1/3] EAPI 6: make in_iuse fatal in global scope
Date: Fri, 16 Oct 2015 10:12:34
Message-Id: 1444990336-16542-2-git-send-email-mgorny@gentoo.org
In Reply to: [gentoo-portage-dev] [PATCHES] EAPI 6 updates by "Michał Górny"
1 Reference: https://archives.gentoo.org/gentoo-pms/message/4a6bb2839e47407fa71cecb19a054375
2 Signed-off-by: Michał Górny <mgorny@g.o>
3 ---
4 bin/ebuild.sh | 1 +
5 1 file changed, 1 insertion(+)
6
7 diff --git a/bin/ebuild.sh b/bin/ebuild.sh
8 index 75a9d24..cc6a22f 100755
9 --- a/bin/ebuild.sh
10 +++ b/bin/ebuild.sh
11 @@ -32,6 +32,7 @@ else
12 # `use multislot` is false for the "depend" phase.
13 funcs="use useq usev"
14 ___eapi_has_usex && funcs+=" usex"
15 + ___eapi_has_in_iuse && funcs+=" in_iuse"
16 for x in ${funcs} ; do
17 eval "${x}() {
18 if ___eapi_disallows_helpers_in_global_scope; then
19 --
20 2.6.1