Gentoo Archives: gentoo-portage-dev

From: Mike Frysinger <vapier@g.o>
To: gentoo-portage-dev@l.g.o
Subject: [gentoo-portage-dev] [rfc] variable naming for marking binaries as QA ignorable
Date: Sat, 04 Mar 2006 04:31:55
1 so we've found some cases where a package installs objects that either need to
2 be ignored by some of the scanelf checks ...
4 first off, we have kernel binary objects that a package installs (the h*modem
5 packages do this), so they should not be subjected to the exec stack scans
7 next up is the slmodem package ... this puppy is partly binary only and we
8 have no access to the source code and upstream is dead ... one of the
9 pre-built binary objects has an exec stack enabled via gcc (meaning it's a
10 legit use of exec stack) ... so we need to skip that
12 what this e-mail is about is naming convention ... i'm thinking that an ebuild
13 sets up a variable with a list of relative paths to $D of files that should
14 be skipped for various checks ... so with slmodem, we'd have like:
15 QA_EXEC_STACK="usr/sbin/slmodemd usr/sbin/slmodem_test"
17 if, in the future, we need to add an ignore list for TEXTRELs, we'd use
18 QA_TEXTRELS="...."
19 -mike
20 --
21 gentoo-portage-dev@g.o mailing list