Gentoo Archives: gentoo-ppc-dev

From: David <david@×××××××××××××××.com>
To: gentooppc-dev@g.o
Subject: Re: [gentooppc-dev] sandbox problems
Date: Fri, 10 May 2002 09:41:54
In Reply to: Re: [gentooppc-dev] sandbox problems by Olivier Reisch
Apparently it's a known issue (well, known to some at least ;-) ).  I 
added warnings to make.conf and make.globals in cvs so people don't turn 
it on.

Note to ppc ebuild writers (if there are any out there...): if at all 
possible, test your ebuilds on x86 too, even if they're ppc-only builds. 
 If you can't, a) pay close attention to the install stage - is DESTDIR 
obeyed fully? b) when you send them in make sure you say that they've 
only been tested on ppc.  That way we can run them through the sandbox 
for you.


Olivier Reisch wrote:

>-----BEGIN PGP SIGNED MESSAGE----- >Hash: SHA1 > >On Thursday 09 May 2002 02:51, David Chamberlain wrote: > > >>Hi all, >> >>I've been experiencing some pretty debilitating problems using the >>sandbox on ppc. Basically portage freezes with no error message when I >>try an emerge or ebuild with sandbox enabled; I can control-C to stop >>it, but emerge -d doesn't give me any useful output. >> >>Anyone else having similar probs? It's hard to test new ebuilds without >>the sandbox turned on :-( >> >>David >> >>_______________________________________________ >>gentooppc-dev mailing list >>gentooppc-dev@g.o >> >> >> > >Hey David, > >I just tried it and indeed, portage seems to freeze on PPC with sandbox turned >on. It froze for me while unpacking package sources. I didn't investigate >further yet... > >Greetings, >Olivier > >- -- > > >