Gentoo Archives: gentoo-ppc-user

From: Nicholas S-A <nova@×××××××××××××.com>
To: gentoo-ppc-user@l.g.o
Subject: [gentoo-ppc-user] problems with PowerBook G4
Date: Wed, 21 Sep 2005 00:40:53
I have installed Gentoo PPC (2005.1) on my 800 Mhz Titanium PowerBook 
G4 successfully (it boots). I have some problems, however, and I was 
wondering if anyone could help me. As it stands, I can not do the 
following which I would like:
1) I cannot configure ethernet (on eth0) or airport (on eth1, wifi1, 
and wlan1). after running "alias eth0=sungem" and "alias eth1=airport", 
"alias wifi1=airport", and "alias wlan1=airport", I still cannot 
connect using net.eth0 and net.eth1, etc, config and ifup eth0/ifup 
eth1. It says (I am booted into OSX now because I cannot get mail from 
Gentoo, so this might be a little off):
ifconfig: eth0: device not found
or something like that. The same goes for eth1. Is there a guide 
somewhere that I could read about configuring ethernet and airport 
under gentoo?
2) I have a problem with my kernel. When I try to boot off of a kernel 
that I complied myself, it always gives " returning 0x01400000 from 
prom_init" as an error in the Open Firmware white background, then NO 
MORE TEXT is outputted, and it freezes. Apparently, this error is 
common with powermac G5's (except with more text and a return to the OF 
prompt), but why my old powerbook has it I do not know. to compile the 
kernel, I ran
make clean dep modules modules_install vmlinux
dep was not needed. My system says making the vmlinux image worked 
fine. however, it does not boot, instead giving the above error. Any 
ideas on how I could get it to work?
3) I cannot mount hfs+ filesystems. When I run
mount /dev/hda13 /mnt/share
mount -t hfs /dev/hda13 /mnt/share
it complains that it does not know what hfs is. What are the steps for 
mounting an hfs+ partition under linux? or should I just switch to UFS?
4) This is a question about Mac-On-Linux. I was wondering how to 
install and run it. I have it installed, but when I run what it says to 
on the man pages, I get some errors about the display, and I think the 
OSX partition (I am really sorry I am so vague, but I forgot it since 
running MOL is not as high a priority right now as getting my linux 
system configured). It does the same thing when run in an xterm or 
Terminal Window (GNOME).
5) How do I configure multiple virtual command lines and switch between 
them? I had it working at one point, but it no longer functions. initrc 
says all the spawn extra terminal commands, but I cannot switch between 
displays using any key commands I know of.

I am pretty sure that most of these errors are due to not having a 
properly configured kernel, but there could be others as well.
thanks in advance for any help,


Subject Author
Re: [gentoo-ppc-user] problems with PowerBook G4 JOAN MASSICH VALL <u1048183@××××××××××.es>
Re: [gentoo-ppc-user] problems with PowerBook G4 Joseph Jezak <josejx@g.o>
Re: [gentoo-ppc-user] problems with PowerBook G4 Colin <signofzeta@×××××.com>