Gentoo Archives: gentoo-ppc-user

From: Joseph Jezak <josejx@g.o>
To: gentoo-ppc-user@l.g.o
Subject: Re: [gentoo-ppc-user] xorg not working.
Date: Sat, 07 Oct 2006 13:58:48
In Reply to: Re: [gentoo-ppc-user] xorg not working. by darren kirby
Hash: SHA1

darren kirby wrote:
> quoth the Joseph Jezak: > > Thanks for the reply, > >> Well, two suggestions here: >> >> 1. From the radeon man page: >> Option "ReverseDDC" "boolean" >> When BIOS connector informations aren't available, use this >> option to reverse the mapping of the 2 main DDC ports. Use this >> if the X serve obviously detects the wrong display for each >> connector. This is typically needed on the Radeon 9600 cards >> bundled with Apple G5s. The default is off. >> >> 2. Try adding >> Option "MergedFB" "false" >> It looks like it's detecting both heads, not monitors attached to >> both heads. > > I tried both of these ideas, separately and together. Seem to be getting > closer. Instead of a blank screen I get random coloured vertical bars on > parts of the screen. Still get this: > > (II) RADEON(0): Primary: > Monitor -- TMDS > Connector -- DVI-D > DAC Type -- TVDAC/ExtDAC > TMDS Type -- Internal > DDC Type -- VGA_DDC > (II) RADEON(0): Secondary: > Monitor -- CRT > Connector -- VGA > DAC Type -- Primary > TMDS Type -- External > DDC Type -- DVI_DDC > > Should note here, there is no VGA connector on the card. There is a DVI > connector (the one I am using) and the one that looks like DVI, but bigger, > ADC I think? > >> If that doesn't work, please let us know. :) >> -Joe > > Still no joy. Sorry for taking so long to get back to the list, I had to go > out... > > -d
Alright, one more thing to test, can you try adding: Option "UseFBDev" "boolean" With either false or true? Stick with it, we'll get it working ;) - -Joe -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.5 (GNU/Linux) Comment: Using GnuPG with Mozilla - iD8DBQFFJ7JrwGq7BLLARfoRAvMIAJ9SCvEJQrr9G95xXXZsvDgG8I5njACgvSnj FyU3+eIZtpCFy6oegPvCxdg= =ptGC -----END PGP SIGNATURE----- -- gentoo-ppc-user@g.o mailing list


Subject Author
Re: [gentoo-ppc-user] xorg not working. darren kirby <bulliver@×××××××××××.org>