Gentoo Archives: gentoo-releng-autobuilds

From: catalyst@×××××××××××××××××××××××××××××.org
To: releng@g.o, gentoo-releng-autobuilds@l.g.o
Subject: [gentoo-releng-autobuilds] [ppc64-auto] Catalyst fatal build error - stage1-32ul.spec
Date: Sun, 28 Feb 2016 16:37:54
Message-Id: 20160228163753.976FF21C001@pigeon.gentoo.org
>>> Regenerating /etc/ld.so.cache...
Adding USE=' build' to make.conf for portage build emerge --quiet --usepkg --buildpkg --newuse --oneshot --update --newuse sys-apps/portage Performing Global Updates (Could take a couple of minutes if you have a lot of binary packages.) @s
>>> Verifying ebuild manifests >>> Emerging (1 of 7) dev-lang/python-exec-2.0.1-r1 >>> Installing (1 of 7) dev-lang/python-exec-2.0.1-r1 >>> Emerging (2 of 7) sys-apps/install-xattr-0.5 >>> Installing (2 of 7) sys-apps/install-xattr-0.5 >>> Emerging (3 of 7) dev-python/packaging-15.3-r2 >>> Installing (3 of 7) dev-python/packaging-15.3-r2 >>> Emerging (4 of 7) dev-python/setuptools-18.4 >>> Installing (4 of 7) dev-python/setuptools-18.4 >>> Emerging (5 of 7) dev-python/certifi-2015.11.20 >>> Installing (5 of 7) dev-python/certifi-2015.11.20 >>> Emerging (6 of 7) dev-python/pyxattr-0.5.5 >>> Installing (6 of 7) dev-python/pyxattr-0.5.5 >>> Emerging (7 of 7) sys-apps/portage-2.2.26 >>> Installing (7 of 7) sys-apps/portage-2.2.26
* Messages for package dev-python/packaging-15.3-r2: * Could not find a UTF-8 locale. This may trigger build failures in * some python packages. Please ensure that a UTF-8 locale is listed in * /etc/locale.gen and run locale-gen. * Messages for package dev-python/setuptools-18.4: * Could not find a UTF-8 locale. This may trigger build failures in * some python packages. Please ensure that a UTF-8 locale is listed in * /etc/locale.gen and run locale-gen. * Messages for package dev-python/certifi-2015.11.20: * Could not find a UTF-8 locale. This may trigger build failures in * some python packages. Please ensure that a UTF-8 locale is listed in * /etc/locale.gen and run locale-gen. * Messages for package dev-python/pyxattr-0.5.5: * Could not find a UTF-8 locale. This may trigger build failures in * some python packages. Please ensure that a UTF-8 locale is listed in * /etc/locale.gen and run locale-gen. * Messages for package sys-apps/portage-2.2.26: * Could not find a UTF-8 locale. This may trigger build failures in * some python packages. Please ensure that a UTF-8 locale is listed in * /etc/locale.gen and run locale-gen. Skipping seed stage update... emerge --quiet --usepkg --buildpkg --newuse --oneshot --nodeps sys-apps/baselayout
>>> Verifying ebuild manifests >>> Emerging (1 of 1) sys-apps/baselayout-2.2::gentoo for /tmp/stage1root/ >>> Installing (1 of 1) sys-apps/baselayout-2.2::gentoo to /tmp/stage1root/
* Messages for package sys-apps/baselayout-2.2 merged to /tmp/stage1root/: * Initializing /tmp/stage1root/lib as a dir * Initializing /tmp/stage1root/usr/lib as a dir * Initializing /tmp/stage1root/usr/local/lib as a dir * Your system profile has SYMLINK_LIB=no, so that means you need to * have these paths configured as follows: * directories: /tmp/stage1root/lib /tmp/stage1root/usr/lib /tmp/stage1root/usr/local/lib * The ebuild will attempt to fix these, but only for trivial conversions. * If things fail, you will need to manually create/move the directories. * Converting /tmp/stage1root/lib from a symlink to a dir * Converting /tmp/stage1root/usr/lib from a symlink to a dir * Converting /tmp/stage1root/usr/local/lib from a symlink to a dir emerge --quiet --usepkg --buildpkg --newuse --oneshot app-arch/bzip2 sys-devel/gnuconfig app-arch/xz-utils sys-apps/file net-misc/wget sys-apps/sed sys-devel/patch sys-devel/binutils sys-apps/findutils sys-apps/grep sys-devel/make sys-devel/bison app-shells/bash sys-devel/autoconf virtual/os-headers sys-apps/coreutils sys-apps/gawk sys-devel/automake virtual/libc virtual/package-manager sys-devel/flex sys-apps/baselayout sys-apps/makedev app-arch/gzip net-misc/rsync sys-devel/libtool sys-apps/net-tools sys-devel/gcc virtual/shadow virtual/editor app-arch/tar virtual/pkgconfig sys-apps/which sys-apps/diffutils sys-devel/gettext sys-apps/less [ebuild U ] sys-libs/ncurses-5.9-r5 [5.9-r3] [ebuild N ] sys-libs/zlib-1.2.8-r1 to /tmp/stage1root/ [ebuild N ] app-arch/bzip2-1.0.6-r6 to /tmp/stage1root/ [ebuild N ] sys-libs/ncurses-5.9-r5 to /tmp/stage1root/ [ebuild N ] virtual/libiconv-0-r2 to /tmp/stage1root/ [ebuild N ] sys-devel/gnuconfig-20150727 to /tmp/stage1root/ [ebuild N ] sys-apps/gentoo-functions-0.10 to /tmp/stage1root/ [ebuild N ] virtual/libintl-0-r2 to /tmp/stage1root/ [ebuild N ] app-arch/xz-utils-5.0.8 to /tmp/stage1root/ [ebuild N ] sys-apps/file-5.22 to /tmp/stage1root/ [ebuild N ] sys-apps/sed-4.2.1-r1 to /tmp/stage1root/ [ebuild N ] app-arch/tar-1.27.1-r2 to /tmp/stage1root/ [ebuild N ] app-misc/editor-wrapper-4 to /tmp/stage1root/ [ebuild N ] sys-devel/gcc-config-1.7.3 to /tmp/stage1root/ [ebuild N ] sys-libs/timezone-data-2015g to /tmp/stage1root/ [ebuild N ] dev-libs/popt-1.16-r2 to /tmp/stage1root/ [binary N ] dev-lang/python-exec-2.0.1-r1 to /tmp/stage1root/ [ebuild N ] dev-libs/libffi-3.0.13-r1 to /tmp/stage1root/ [ebuild N ] sys-apps/shadow-4.1.5.1-r1 to /tmp/stage1root/ [ebuild N ] sys-devel/patch-2.7.5 to /tmp/stage1root/ [ebuild N ] sys-apps/findutils-4.4.2-r1 to /tmp/stage1root/ [ebuild N ] sys-devel/make-4.1-r1 to /tmp/stage1root/ [ebuild N ] sys-apps/gawk-4.0.2 to /tmp/stage1root/ [ebuild R ] sys-apps/baselayout-2.2 to /tmp/stage1root/ [ebuild N ] app-arch/gzip-1.6 to /tmp/stage1root/ [ebuild N ] sys-apps/which-2.20-r1 to /tmp/stage1root/ [ebuild U ] sys-devel/automake-wrapper-10 [9] [ebuild N ] dev-libs/expat-2.1.0-r5 to /tmp/stage1root/ [ebuild N ] sys-devel/automake-wrapper-10 to /tmp/stage1root/ [ebuild N ] sys-devel/autoconf-wrapper-13 to /tmp/stage1root/ [ebuild N ] dev-util/pkgconfig-0.28-r2 to /tmp/stage1root/ [ebuild N ] sys-apps/makedev-3.23.1 to /tmp/stage1root/ [ebuild N ] dev-libs/gmp-6.0.0a to /tmp/stage1root/ [ebuild N ] sys-libs/ncurses-5.9-r99 to /tmp/stage1root/ [ebuild N ] sys-apps/coreutils-8.23 to /tmp/stage1root/ [ebuild N ] virtual/libffi-3.0.13-r1 to /tmp/stage1root/ [ebuild N ] sys-devel/binutils-config-4-r2 to /tmp/stage1root/ [ebuild N ] sys-apps/sandbox-2.10-r1 to /tmp/stage1root/ [ebuild N ] app-misc/pax-utils-1.0.3 to /tmp/stage1root/ [ebuild N ] sys-apps/net-tools-1.60_p20141019041918-r1 to /tmp/stage1root/ [ebuild N ] virtual/shadow-0 to /tmp/stage1root/ [ebuild N ] sys-apps/diffutils-3.3 to /tmp/stage1root/ [ebuild N ] sys-apps/less-481 to /tmp/stage1root/ [ebuild N ] sys-devel/m4-1.4.16 to /tmp/stage1root/ [ebuild N ] dev-libs/libltdl-2.4.6 [ebuild N ] dev-libs/libltdl-2.4.6 to /tmp/stage1root/ [ebuild N ] virtual/pkgconfig-0-r1 to /tmp/stage1root/ [ebuild N ] dev-libs/mpfr-3.1.3_p4 to /tmp/stage1root/ [ebuild N ] sys-devel/bison-2.7.1 to /tmp/stage1root/ [ebuild N ] sys-devel/flex-2.5.39-r1 to /tmp/stage1root/ [ebuild N ] dev-libs/mpc-1.0.2-r1 to /tmp/stage1root/ [ebuild N ] sys-devel/binutils-2.25.1-r1 to /tmp/stage1root/ [ebuild N ] app-admin/eselect-1.4.4 to /tmp/stage1root/ [ebuild N ] app-eselect/eselect-python-20111108 to /tmp/stage1root/ [ebuild N ] sys-kernel/linux-headers-4.3 to /tmp/stage1root/ [ebuild N ] virtual/os-headers-0 to /tmp/stage1root/ [ebuild N ] dev-lang/perl-5.20.2 to /tmp/stage1root/ [ebuild N ] perl-core/Data-Dumper-2.154.0 to /tmp/stage1root/ [ebuild N ] virtual/perl-Data-Dumper-2.154.0 to /tmp/stage1root/ [ebuild N ] perl-core/File-Temp-0.230.400-r1 to /tmp/stage1root/ [ebuild N ] virtual/perl-File-Temp-0.230.400-r3 to /tmp/stage1root/ [ebuild N ] sys-devel/autoconf-2.69 to /tmp/stage1root/ [ebuild U ] sys-libs/readline-6.3_p8-r2 [6.2_p5-r1] [ebuild N ] sys-libs/glibc-2.21-r2 to /tmp/stage1root/ [ebuild N ] sys-libs/readline-6.3_p8-r2 to /tmp/stage1root/ [ebuild N ] app-shells/bash-4.3_p42-r1 to /tmp/stage1root/ [ebuild N ] app-editors/nano-2.4.3 to /tmp/stage1root/ [ebuild NS ] sys-devel/automake-1.15 [1.13.4] [ebuild N ] sys-devel/automake-1.15 to /tmp/stage1root/ [ebuild N ] dev-libs/libxml2-2.9.2-r4 to /tmp/stage1root/ [ebuild N ] dev-libs/iniparser-3.1-r1 [ebuild N ] dev-libs/iniparser-3.1-r1 to /tmp/stage1root/ [ebuild N ] app-portage/portage-utils-0.56 to /tmp/stage1root/ [ebuild N ] dev-lang/python-3.4.3-r1 to /tmp/stage1root/ [ebuild N ] dev-lang/python-2.7.10-r1 to /tmp/stage1root/ [ebuild N ] sys-apps/portage-2.2.26 to /tmp/stage1root/ [ebuild N ] app-admin/perl-cleaner-2.19 to /tmp/stage1root/ [ebuild N ] app-admin/python-updater-0.11 to /tmp/stage1root/ [ebuild N ] net-misc/wget-1.16.3-r1 to /tmp/stage1root/ [ebuild N ] sys-apps/grep-2.21-r1 to /tmp/stage1root/ [ebuild N ] virtual/libc-0 to /tmp/stage1root/ [ebuild N ] virtual/package-manager-0 to /tmp/stage1root/ [ebuild N ] net-misc/rsync-3.1.2 to /tmp/stage1root/ [ebuild N ] sys-devel/gcc-4.9.3 to /tmp/stage1root/ [ebuild N ] virtual/editor-0 to /tmp/stage1root/ [ebuild N ] sys-devel/libtool-2.4.6 to /tmp/stage1root/ [ebuild N ] sys-devel/gettext-0.19.4 to /tmp/stage1root/ [blocks B ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.6) * Error: The above package list contains packages which cannot be * installed at the same time on the same system. (dev-libs/libltdl-2.4.6:0/0::gentoo, ebuild scheduled for merge) pulled in by dev-libs/libltdl:0 required by (sys-devel/libtool-2.4.6:2/2::gentoo, ebuild scheduled for merge to '/tmp/stage1root/') (sys-devel/libtool-2.4.2-r1:2/2::gentoo, installed) pulled in by sys-devel/libtool required by (dev-libs/iniparser-3.1-r1:0/0::gentoo, ebuild scheduled for merge to '/tmp/stage1root/') >=sys-devel/libtool-2.4 required by (dev-libs/iniparser-3.1-r1:0/0::gentoo, ebuild scheduled for merge) >=sys-devel/libtool-2.4 required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, ebuild scheduled for merge to '/tmp/stage1root/') >=sys-devel/libtool-2.4 required by (dev-libs/iniparser-3.1-r1:0/0::gentoo, ebuild scheduled for merge to '/tmp/stage1root/') sys-devel/libtool required by (dev-libs/iniparser-3.1-r1:0/0::gentoo, ebuild scheduled for merge) !!! catalyst: run script failed. Traceback (most recent call last): File "modules/generic_stage_target.py", line 1244, in run_local "run script failed.",env=self.env) File "/usr/lib/catalyst/modules/catalyst_support.py", line 541, in cmd raise CatalystError,myexc CatalystError None !!! catalyst: Stage build aborting due to error. Traceback (most recent call last): File "/usr/lib/catalyst/catalyst", line 218, in build_target mytarget.run() File "modules/generic_stage_target.py", line 1304, in run apply(getattr(self,x)) File "modules/generic_stage_target.py", line 1249, in run_local raise CatalystError,"Stage build aborting due to error." CatalystError !!! catalyst: Error encountered during run of target stage1 Catalyst aborting.... lockfile does not exist '/var/tmp/catalyst/tmp/default/stage1-ppc64-32ul-20160228/.catalyst_lock' Full build log at /tmp/catalyst-auto.dTsaGy/log/stage1-32ul.log