Gentoo Archives: gentoo-releng

From: Brad House <brad_mssw@g.o>
To: Martin Schlemmer <azarah@g.o>
Cc: gentoo-releng@l.g.o
Subject: Re: [gentoo-releng] x86-livecd - bugs and suggestions
Date: Sun, 25 Jan 2004 16:29:10
In Reply to: Re: [gentoo-releng] x86-livecd - bugs and suggestions by Martin Schlemmer
>> Works well, though we seem to be getting an error when it tries to start >> hotplug from within the autoconfig script about needing to run >> /sbin/ I made it run /sbin/depscan during the livecd >> creation >> to try to get rid of this error, but it did not seem to help, so I'm not >> sure under what circumstances this can occur, but it does seem that >> hotplug does start, and works properly, so I'm somewhat at a loss, other >> than that, the livecd seems to be 100% in sync with the previous livecds >> at this point. >> > > What type of fs is / once booted ? Also, when abouts is the autoconfig > script run?
/ ends up on a tmpfs, with symlinks back to the read-only livecd stuff for the main directories, and /etc is also on a tmpfs so it's writable. Autoconfig I made have a dep on 'need modules', so it gets run sometime after the manually specified modules are loaded, but before local which is 'after *'. It seemed it started _right_ before local on my system though. (the autoconfig script I'm using is in this small tarball: incase you wanted to look at how it calls hotplug) -Brad -- gentoo-releng@g.o mailing list


Subject Author
Re: [gentoo-releng] x86-livecd - bugs and suggestions Martin Schlemmer <azarah@g.o>