Gentoo Archives: gentoo-science

From: v_2e@×××.net
To: gentoo-science@l.g.o
Subject: [gentoo-science] [sage-on-gentoo] Sage-4.5.2 build problem and a "run-time" errors.
Date: Wed, 11 Aug 2010 06:18:34
Message-Id: 20100811091847.69233077.v_2e@ukr.net
Hello!
I've got some problems after upgrading Sage to 4.5.1 and to 4.5.2 after
that.
First of all, sage-baselayout-4.5.2 blocks sage-4.5.2, but if I delete
the "DEPEND="!!<sci-mathematics/sage-4.5.2"" line from 
/var/lib/layman/sage-on-gentoo/sci-mathematics/sage-baselayout/sage-baselayout-4.5.2.ebuild
file, I can emerge it.
Still, after starting Sage I get this error message:

########## Qoute begins ##########
ImportError                               Traceback (most recent call
last)

/usr/lib64/python2.6/site-packages/IPython/ipmaker.pyc in force_import
(modname, force_reload) 61         reload(sys.modules[modname])
     62     else:
---> 63         __import__(modname)
     64         
     65 

/usr/bin/ipy_profile_sage.py in <module>()
      5     preparser(True)
      6     
----> 7     import sage.all_cmdline
      8     sage.all_cmdline._init_cmdline(globals())
      9     

/usr/lib64/python2.6/site-packages/sage/all_cmdline.py in <module>()
     12 try:
     13 
---> 14     from sage.all import *
     15     from sage.calculus.predefined import x
     16     preparser(on=True)

/usr/lib64/python2.6/site-packages/sage/all.py in <module>()
     71 
     72 from sage.rings.all      import *
---> 73 from sage.matrix.all     import *
     74 
     75 # This must come before Calculus -- it initializes the Pynac
library.

/usr/lib64/python2.6/site-packages/sage/matrix/all.py in <module>()
----> 1 
      2 
      3 from matrix_space import MatrixSpace, is_MatrixSpace
      4 from constructor import matrix, Matrix, random_matrix,
diagonal_matrix, identity_matrix, block_matrix, block_diagonal_matrix,
jordan_block, zero_matrix 5 from matrix import is_Matrix 6 from
berlekamp_massey import berlekamp_massey 7 

/usr/lib64/python2.6/site-packages/sage/matrix/matrix_space.pyc in
<module>() 35 import matrix_generic_sparse
     36 
---> 37 import matrix_modn_dense
     38 import matrix_modn_sparse
     39 

/usr/bin/matrix_integer_dense.pxd in init sage.matrix.matrix_modn_dense
(sage/matrix/matrix_modn_dense.c:14829)() 10 
     11 
---> 12 
     13 
     14 

/usr/bin/linbox.pxd in init sage.matrix.matrix_integer_dense
(sage/matrix/matrix_integer_dense.c:39016)() 5 
      6 
----> 7 
      8 
      9 

ImportError: /usr/lib/liblinboxsage.so.0: undefined symbol: dgetri_
Error importing ipy_profile_sage - perhaps you should run %upgrade?
WARNING: Loading of ipy_profile_sage failed.
########### Qoute ends ##########


----- 
 <v_2e@×××.net>

Replies

Subject Author
Re: [gentoo-science] [sage-on-gentoo] Sage-4.5.2 build problem and a "run-time" errors. Christopher Schwan <cschwan@××××××××××××××××××.de>