Gentoo Archives: gentoo-science

From: Andrea Arteaga <andyspiros@×××××.com>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] blas/lapack stuff
Date: Tue, 11 Oct 2011 07:44:30
In Reply to: [gentoo-science] blas/lapack stuff by "Andrey G. Grozin"
Hello Andrey,

the (c)blas/lapack framework has changed a bit. The eselect-blas,
eselect-lapack, eselect-* packages are now deprecated. In order to
access the new versions of these libraries and the new eselect package
you have to remove the old ones (I mean eselect-*), install
eselect-1.2.18-r1, blas-reference-20110418 (or any other
implementation of your choice, like atlas of openblas). In general,
you can safely emerge the blas implementations listed in virtual/blas
[1], virtual/cblas, virtual/lapack,...

Notice that most of these packages are ~keyworded, so if you want to
stay with stable packages you will be unable to install the newest
versions of blas and lapack, as they need the patched eselect.

Also notice that now atlas-3.9.* provides blas, cblas and lapack;
blas-atlas, cblas-atlas are not needed anymore.

This also applies to blacs, lapacke, scalapack, mpi.




Subject Author
[gentoo-science] sci-mathematics/reduce on amd64 "Andrey G. Grozin" <A.G.Grozin@×××××××.su>
Re: [gentoo-science] blas/lapack stuff "Andrey G. Grozin" <A.G.Grozin@×××××××.su>