Gentoo Archives: gentoo-science

From: Juergen Rose <rose@××××××××××××××.de>
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1
Date: Mon, 10 Oct 2011 00:00:35
Message-Id: 1318204812.17496.3.camel@impala.homenet
In Reply to: Re: [gentoo-science] sci-mathematics/sage-4.7.1-r2 still circumvents the installation of numpy > numpy-1.5.1 by fbissey@slingshot.co.nz
On Mon, 2011-10-10 at 12:25 +1300, fbissey@××××××××××××.nz wrote:
> Quoting rose@××××××××××××××.de: > >> > >> Do you absolutely need numpy-1.6 for something else than sage? > >> > >> Francois > > > > Hi Francois, > > > > it seems, that scipy-0.9.0-r2 fails to emerge if numpy-1.5.1 is > > installed but it is emerged if numpy-1.6.1-r1, compare Bug 386269 > > https://bugs.gentoo.org/show_bug.cgi?id=386269 . > > > > Regards Juergen > Hi Juergen, > > It works for me here so let's try to get to the bottom of this. > Do you have lapack enabled in numpy? > > Francois
Yes, I have. at the system with installed sage: root@caiman:/root(28)# emerge -pvD numpy These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-python/numpy-1.5.1 USE="doc lapack -test" 0 kB Total: 1 package (1 reinstall), Size of downloads: 0 kB WARNING: One or more updates have been skipped due to a dependency conflict: dev-python/numpy:0 (dev-python/numpy-1.6.1-r1::gentoo, ebuild scheduled for merge) conflicts with ~dev-python/numpy-1.5.1 required by (sci-mathematics/sage-4.7.1-r2::sage-on-gentoo, installed) and on the system without sage: root@condor:/root(13)# emerge -pvD numpy These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-python/numpy-1.6.1-r1 USE="doc lapack -test" 0 kB