Gentoo Archives: gentoo-science

From: fbissey@××××××××××××.nz
To: gentoo-science@l.g.o
Subject: Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version
Date: Wed, 24 Aug 2011 22:30:02
In Reply to: Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version by Steven Trogdon
Quoting Steven Trogdon <strogdon@×××××.edu>:

> On Wed, 24 Aug 2011 12:03:19 +0200 > rose@××××××××××××××.de wrote: > >> Hi, >> >> I just installed more or less succesful sage. During the >> installation numpy was downgraded from numpy-1.6.1 to numpy-1.5.1. >> Now every 'emerge -uvDN world' complaines about; >> >> WARNING: One or more updates have been skipped due to a dependency conflict: >> >> dev-python/numpy:0 >> >> (dev-python/numpy-1.6.1::gentoo, ebuild scheduled for merge) >> conflicts with >> ~dev-python/numpy-1.5.1 required by >> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed) >> >> dev-python/pexpect:0 >> >> (dev-python/pexpect-2.4-r1::sage-on-gentoo, ebuild scheduled for >> merge) conflicts with >> ~dev-python/pexpect-2.0 required by >> (sci-mathematics/sage-4.7.1::sage-on-gentoo, installed) >> >> If I try to install couchdb, numpy-1.6.1 will be installed again: >> >> root@caiman:/root(4)# emerge -pvuDN couchdb >> >> These are the packages that would be merged, in order: >> >> Calculating dependencies... done! >> [ebuild N ] dev-lang/erlang-14.2.3 USE="doc emacs java odbc >> smp ssl tk wxwidgets -halfword -hipe -kpoll -sctp" 98,075 kB >> [ebuild N ] dev-db/couchdb-1.1.0 USE="-test" 1,063 kB >> [ebuild U ] dev-python/numpy-1.6.1 [1.5.1] USE="doc lapack -test" 0 kB >> >> Should I mask numpy-1.6.1 or how are the chances that sage will work >> with numpy-1.6.1? >> > At least until this Bug > > > > is resolved (sog) sage requires ~numpy-1.5.1 > > I'm not sure exactly the impact on your system of masking > >=numpy-1.6.0 but you > could try that and see what emerge -puDNv world gives. I don't see which > component, if any, of couchdb is pulling in numpy or where else numpy is > needed on your system. Oh, and you will also have to mask >=pexpect-2.4 >
Hi all, Sorry I needed to have a little break. numpy-1.6+ is not compatible with sage at the moment: so don't try it. I suspect numpy wants to upgrade to 1.6.1 for you for the following reason: 1) you put numpy in your package.keywords file 2) numpy is part of your world set. It is upgraded independently of any dependency requirement. The fact that it is pulled just by -D is somewhat a bug in portage - although there could be a web of dependencies leading to numpy. emerge -puNv couchdb probably won't pick it. If you downgraded from numpy-1.6.x to 1.5.1 don't forget to rebuild scipy. Francois


Subject Author
Re: [gentoo-science] sci-mathematics/sage-4.7.1 and numpy version P Purkayastha <ppurka@×××××.com>