Gentoo Archives: gentoo-sparc

From: Ferris McCormick <fmccor@g.o>
To: Gentoo Sparc <gentoo-sparc@l.g.o>
Subject: [gentoo-sparc] [Fwd: Re: xorg-x11-7.1 (X-modular) is stable on sparc and in sync with x86.]
Date: Wed, 23 Aug 2006 20:32:49
-------- Forwarded Message --------
From: Donnie Berkholz <dberkholz@g.o>
To: Ferris McCormick <fmccor@g.o>
Subject: Re: xorg-x11-7.1 (X-modular) is stable on sparc and in sync
with x86.
Date: Wed, 23 Aug 2006 10:21:40 -0700

[off-list, since I'm not subscribed to it]

Ferris McCormick wrote:
> If you are running xorg-x11-6.8.2-r8 and are suddenly confronted with > a huge update to 7.1 but do not wish to convert blind, you should be > able to mask the upgrade in your /etc/portage/package.mask file, thus: >> =x11-base/xorg-x11-7.0
You may also want to mask >=virtual/x11-7 since virtual/x11 is what packages actually use in dependencies -- I'm not actually sure whether this is necessary, though.
> But do not depend on this forever, because the xorg-x11-6.8.2 group will > disappear at some point (and if you happen to be using 6.9.0, long term > that is probably not a good strategy either).
Monolithic X is no longer guaranteed to receive patches for security vulnerabilities, and there's already a denial of service with potential code execution that's been fixed only in modular X. Thanks, Donnie -- Ferris McCormick (P44646, MI) <fmccor@g.o> Developer, Gentoo Linux (Devrel, Sparc)


File name MIME type
signature.asc application/pgp-signature