Gentoo Archives: gentoo-user-de

From: mailinglist <mailing_list@×××.net>
To: gentoo-user-de@l.g.o
Subject: Re: [gentoo-user-de] Timeouts bei Geraeteerkennung auf einem Thinkpad T410 mit Systemd
Date: Thu, 09 Oct 2014 08:47:13
Message-Id: 20141009104708.00007c6e@gmx.net
Am Thu, 09 Oct 2014 08:43:29 +0200
schrieb Simon Siebert <mail@××××××××××××.de>:

Guten Morgen,

bei der Verwendung von Grub2 muss dort die Zeile

GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

in die Datei /etc/default/grub eingetragen und danach ein

grub2-mkconfig -o /boot/grub/grub.cfg

ausgeführt werden. 

Beste Grüße
Christian

> Guten Morgen, > ich denke eine systemd pro/contra Diskussion ist hier unnötig. > > Zum Problem. > Bei installieren von systemd via emerge weist das ebuild auf einige > kernel Optionen hin, welche gesetzt sein müssen. Sind die alle > gesetzt bzw stimmen mit dem was systemd erwartet überein? > > Gruß > Simon > > Am 07.10.2014 15:27 schrieb Juergen Rose <rose@××××××××××××××.de>: > > > > Am Dienstag, den 07.10.2014, 11:42 +0200 schrieb Juergen Rose: > > > > > Vielleicht habe ich die Ursache gefunden. Ich hatte drei (Gruppen > > > von) Kerneloptionen gesetzt, die wahrscheinlich fuer meine > > > Hardware ungeeignet waren: > > > 1. > > >   CONFIG_CALGARY_IOMMU=y > > >   CONFIG_CALGARY_IOMMU_ENABLED_BY_DEFAULT=y > > > 2. > > >   CONFIG_COMPAT_VDSO=y > > > 3. > > >   CONFIG_HOTPLUG_PCI=y > > >   CONFIG_HOTPLUG_PCI_ACPI=y > > >   CONFIG_HOTPLUG_PCI_ACPI_IBM=y > > > > > > Jetzt habe ich den Kernel mit: > > > 1. > > > # CONFIG_CALGARY_IOMMU is not set > > > 2. > > > # CONFIG_COMPAT_VDSO is not set > > > 3. > > > # CONFIG_HOTPLUG_PCI is not set > > > > > > uebersetzt. Beim darauffolgenden Booten scheinen alle meine > > > Probleme erst einmal verschwunden zu sein. Mal sehen, was die > > > naechsten Bootversuche sagen. > > > > > > Juergen > > > > Ich habe mich zu frueh gefreut. Beim letzten (erfolgreichen) > > Bootversuch hat der Kernel noch gemeckert, dass er das hdaps-Modul > > nicht laden kann. Dieses Problem konnte ich durch disablen des > > Kernel-hdaps-Modul loesen. Nun wird beim Booten das hdaps-Modul von > > tp_smapi ohne Probleme geladen. Leider tauchen danach wieder alle > > Timeouts, die ich in meiner ersten Mail beschrieben habe, wieder > > auf. Weiterhin wird wieder ueber den Fehler beim Zugriff > > /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/power/control > > gemeckert (diese Datei existiert nicht). Der sendmail.service, > > systemd-logind.service und der colord.service und damit das > > Multi-User.target wird nicht gestartet. > > > > Juergen > > > > > >

Replies

Subject Author
Re: [gentoo-user-de] Timeouts bei Geraeteerkennung auf einem Thinkpad T410 mit Systemd Michael Volland <mk106c-gnu@×××××.de>