Gentoo Archives: gentoo-user-de

From: Juergen Rose <rose@××××××××××××××.de>
To: gentoo-user-de@l.g.o
Subject: [gentoo-user-de] acroread, 64-Bit und "Cannot open pixbuf loader"
Date: Wed, 16 Dec 2009 18:11:40
Message-Id: 1260981487.14345.23.camel@moose.ibmt.intern
Hallo,

seit einiger Zeit funktioniert die Schriftdarstellung der Menues von
Acroread auf 64-Bit-Rechnern bei mir nicht mehr. Beim Start von acroread
erhalte ich zuerst die Mitteilung, dass libcanberra-gtk-module.so und 
libgnomebreakpad.so nicht geöffnet werden kann dann endlos Warnungen von
der folgenden Art: 

(acroread.de:12921): GLib-GObject-CRITICAL **: g_object_ref: assertion
`G_IS_OBJECT (object)' failed

(acroread.de:22746): Pango-WARNING
**: /usr/lib64/pango/1.6.0/modules/pango-basic-fc.so: wrong ELF class:
ELFCLASS64

(acroread.de:22746): GdkPixbuf-WARNING **: Cannot open pixbuf loader
module file '/etc/gtk-2.0/gdk-pixbuf.loaders': Datei oder Verzeichnis
nicht gefunden

(acroread.de:22746): GdkPixbuf-WARNING **: Error loading XPM image
loader: Bildtyp »xpm« wird nicht unterstützt

(acroread.de:12921): Gdk-CRITICAL **: gdk_window_set_icon_list:
assertion `GDK_IS_PIXBUF (pixbuf)' failed


Eine Datei /etc/gtk-2.0/gdk-pixbuf.loaders gibt es bei mir nicht. Dafuer
habe ich:

moose ~ # ll  /etc/gtk-2.0/*/gdk-pixbuf.loader*
-rw-r--r-- 1 root root 3116 Nov  9
18:12 /etc/gtk-2.0/i686-pc-linux-gnu/gdk-pixbuf.loaders
-rw-r--r-- 1 root root 4338 Dec 16
12:51 /etc/gtk-2.0/x86_64-pc-linux-gnu/gdk-pixbuf.loaders


Die Ursache liegt vermutlich in der unvollstaendigen 32-Bit-Emulation.
Ich habe die folgenden emul-linux-x86-Pakete installiert:

moose ~ # qlist -Iv emul-linux-x86
app-emulation/emul-linux-x86-baselibs-20091004_rc1
app-emulation/emul-linux-x86-compat-20091004_rc1
app-emulation/emul-linux-x86-gtklibs-20091004_rc1
app-emulation/emul-linux-x86-medialibs-20091004_rc1
app-emulation/emul-linux-x86-qtlibs-20091004_rc1
app-emulation/emul-linux-x86-sdl-20091004_rc1
app-emulation/emul-linux-x86-soundlibs-20091004_rc1
app-emulation/emul-linux-x86-xlibs-20091004_rc1

Kann mir jemand Tips geben, wie man acroread auf 64-Bit Systemen zum
Laufen bringt? Ich weiss, es gibt auch evince und xpdf, aber beide
zeigen mir keine in PDF-Dateien vorhandene http-URLs an. 


-- 
Juergen Rose <rose@××××××××××××××.de>
Uni-Potsdam