Gentoo Archives: gentoo-user-de

From: Torsten Streit <barney@××××××.de>
To: "#gentoo.de" <gentoo-user-de@l.g.o>
Subject: [gentoo-user-de] Vixie-cron Zombies
Date: Sat, 20 Nov 2004 20:53:17
Message-Id: 1100983995.15153.0.camel@elvira.barnal.lan
Hi Leute... 

Seit geraumer Zeit hat mein vixie-cron die angewohnheit massig Zombies
zu hinterlassen. Zumindest sobald einer der cronjobs eine Nachricht per
mail (mta postfix) zurückgeben will. 

Prozessunabhängig sieht das ganze dann folgend aus: 
13575 ? 00:00:00 cron 
13576 ? 00:00:00 bash <defunct> 
13656 ? 00:00:00 sendmail 
13657 ? 00:00:00 postdrop 
13658 ? 00:00:00 <eigentlicher_prozess> 
13730 ? 00:00:00 smtpd 
13732 ? 00:00:00 pipe 

Die bleiben dann alle so bis ich den cron kille. Selbsterklärend das
mein Server mit ca 50 crons damit so seine Probleme bekommt nach einigen
Tagen... ;)

Versucht hab ich bisher: 
- Neuinstallation Postfix 
- Neuinstallation vixie-cron (auch fcron schon getestet, das gleiche) 
- Diverse Änderungen an den cronjobs (testhalber, die haben bisher aber
immer funktioniert) 

Ergänzendes: 
Ich hab das Problem mit allen useraccounts, also nicht spezifisch.
Ausserdem läuft der Postfix 1a, ich kann lokal hin und her mailen,
extern geht sowieso da noch einige usermailadressen und mailinglisten
dort laufen... 

Bugliste hab ich bereits durchsucht, nichts passendes dazu gefunden. 


Demnach bin ich für jede Art von Tip offen :)
-- 

-------------------------------------
Torsten Streit
www.barnal.de -senseless funstuff-
-------------------------------------


--
gentoo-user-de@g.o mailing list

Replies

Subject Author
Re: [gentoo-user-de] Vixie-cron Zombies Erik Wasser <erik.wasser@×××××.net>