Gentoo Archives: gentoo-user-fr

From: Christophe PEREZ <christophe.perez@×××××××.com>
To: gentoo-user-fr@l.g.o
Subject: [gentoo-user-fr] mplayer instruction illégale
Date: Mon, 26 Sep 2005 17:47:52
Message-Id: pan.2005.09.26.17.47.28.386000@novazur.fr
Bonjour,

Sur une de mes machines, je constate que mplayer plante maintenant
systématiquement avec un :
MPlayer 1.0pre7try2-3.3.6 (C) 2000-2005 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compilé pour CPU x86 avec les extensions: MMX MMX2 SSE


Instruction illégale


Quand je fais des recherches, je constate que beaucoup de gens ont eu ça
quand ils avaient utilisé des options de compilation (3dnow en
particulier) que leur processeur ne supportait pas.

Pourtant, là, ça ne semble pas être mon cas :
# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 798.001
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 1576.96

Je viens d'ajouter le mmx2 et de recompiler avec, pour test, mais je ne
l'avais pas lorsque j'ai découvert cette erreur.

Certains parlent aussi de ffmpeg à recompiler, et là, j'ai eu la
surprise de constater que ffmpeg n'était même pas installé sur cette
machine. N'est-ce pourtant pas obligatoire pour mplayer ?
Aurais-je loupé quelque chose quelque part dans ma config ?

Je viens d'installer ffmpeg, mais ça n'a rien changé.
Dois-je recompiler mplayer ?

Ce qui me semble bizarre, c'est que revdep-rebuild ne m'ait rien donné
avant l'install de ffmpeg.

Je précise qu'il y a quelques temps, probablement avant une mise à jour
quelconque, mplayer fonctionnait parfaitement sur cette machine.

-- 
Christophe PEREZ
-- 
gentoo-user-fr@g.o mailing list

Replies

Subject Author
Re: [gentoo-user-fr] mplayer instruction illégale Aurelien Francillon <aurel@××××××.org>