Gentoo Archives: gentoo-user

From: Robert S <robert.spam.me.senseless@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] KDE 3.4.0 tp 3.4.1. KDE no longer starts
Date: Sat, 30 Jul 2005 22:44:31
Message-Id: 7093dffb05073015381a403289@mail.gmail.com
I have recently upgraded from kde 3.4.0 to 3.4.1.  I am now unable to
access my kde desktop.  When I go from "startx" or log in from kdm, I
briefly see my desktop and the Panel, then I get the KDE crash
handler, which gives a message along the lines of "The KDE session
manager ksmserver crashed and caused signal 11...".  I get the
following output on the command line:

startkde: Starting up...
kbuildsycoca running...
KWrited - Listening on Device /dev/pts/1
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/computer
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio
on device with id /org/freedesktop/Hal/devices/block_3_4
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/ide_1_1
libhal.c 911 : Error sending msg: No property info.category on device
with id /org/freedesktop/Hal/devices/ide_1_1
kdecore (KLibLoader): WARNING: KLibrary:
/usr/kde/3.4/lib/kde3/kcm_kdnssd.so: undefined symbol: init_kdnssd
SetClientVersion: 0 8
KCrash: Application 'ksmserver' crashing...
ICE default IO error handler doing an exit(), pid = 9643, errno = 0
ICE default IO error handler doing an exit(), pid = 9645, errno = 0
Session management error: Could not open network socket
main
gentooWatcher::getPortageGlsa
Session management error: Could not open network socket
ICE default IO error handler doing an exit(), pid = 9647, errno = 0
gentooWatcher::getPortageRss
startkde: Shutting down...
klauncher: Exiting on signal 1
startkde: Running shutdown scripts...
startkde: Done.

Can anybody help?  I've tried re-emerging a number of packages
including hal, kdelibs etc.

Looks like a problem with hal maybe??

-- 
gentoo-user@g.o mailing list