Gentoo Archives: gentoo-user

From: Mick <michaelkintzios@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] gst-plugins blocker
Date: Tue, 21 Nov 2017 13:03:43
Message-Id: 10722946.cdUo8gDnx2@dell_xps
I see that <media-libs/gst-plugins-bad-1.11.90:1.0 is blocking media-libs/gst-
plugins-base-1.12.3, so I removed various gst-plugins and net-libs/farstream, 
emerged -1 media-libs/gst-plugins-base-1.12.3, but portage continues to 
complain, with backtrack=99 or not.

What is the way to overcome this?

=================================
# emerge @preserved-rebuild -v -a

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/gst-plugins-bad-1.10.5:1.0::gentoo  USE="X bzip2 
egl introspection nls opengl orc vnc wayland -gles2 -gtk {-test} -vcd" 
ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-plugins/gst-plugins-libnice-0.1.13-r100:1.0::gentoo  
ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] media-libs/gst-plugins-good-1.10.5:1.0::gentoo  USE="nls orc" 
ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] net-libs/farstream-0.2.8-r1:0.2/5::gentoo  USE="introspection 
{-test} -upnp" 0 KiB
[ebuild   R    ] net-im/pidgin-2.12.0:0/2::gentoo  USE="dbus gstreamer gtk 
ncurses nls spell xscreensaver (-aqua) -debug -doc -eds -gadu -gnutls -
groupwise -idn -meanwhile -networkmanager -perl -pie -prediction -python -sasl 
-silc -tcl -tk -zephyr -zeroconf" PYTHON_TARGETS="python2_7" 0 KiB
[blocks B      ] <media-libs/gst-plugins-bad-1.11.90:1.0 ("<media-libs/gst-
plugins-bad-1.11.90:1.0" is blocking media-libs/gst-plugins-base-1.12.3)

Total: 5 packages (4 new, 1 reinstall), Size of downloads: 0 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/gst-plugins-base-1.12.3:1.0/1.0::gentoo, installed) pulled in by
    media-libs/gst-plugins-base:1.0 required by (net-im/
pidgin-2.12.0:0/2::gentoo, ebuild scheduled for merge)
    >=media-libs/gst-plugins-base-1.4:1.0 required by (net-libs/
farstream-0.2.8-r1:0.2/5::gentoo, ebuild scheduled for merge)
    >=media-libs/gst-plugins-
base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] 
(>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_64(-)]) required by (media-
libs/gst-plugins-good-1.10.5:1.0/1.0::gentoo, ebuild scheduled for merge)
    media-libs/gst-plugins-base:
1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] 
(media-libs/gst-plugins-base:1.0[abi_x86_64(-)]) required by (media-plugins/
gst-plugins-libnice-0.1.13-r100:1.0/1.0::gentoo, ebuild scheduled for merge)
    >=media-libs/gst-plugins-
base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,introspection?] 
(>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_64(-),introspection]) 
required by (media-libs/gst-plugins-bad-1.10.5:1.0/1.0::gentoo, ebuild 
scheduled for merge)

  (media-libs/gst-plugins-bad-1.10.5:1.0/1.0::gentoo, ebuild scheduled for 
merge) pulled in by
    >=media-libs/gst-plugins-bad-1.4:1.0 required by (net-libs/
farstream-0.2.8-r1:0.2/5::gentoo, ebuild scheduled for merge)
=================================

-- 
Regards,
Mick

Attachments

File name MIME type
signature.asc application/pgp-signature

Replies

Subject Author
Re: [gentoo-user] gst-plugins blocker Alan McKinnon <alan.mckinnon@×××××.com>