Gentoo Archives: gentoo-user

From: Andrew Gaydenko <a@××××××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] KDE3 apps installation fails...
Date: Wed, 25 Feb 2009 12:33:57
Message-Id: 200902251533.32179.a@gaydenko.com
...with the same error shown below (the error takes place for, say, 
soundkonverter, tellico, ...). I have KDE4 installed (~amd64), but some KDE3 
libs and apps are still in use also (ones which were not upgraded during KDE4 
installation).

How to resolve the issue?

-----------------------------------------------------------
...
checking for KDE... libraries /usr/kde/3.5/lib64, headers /usr/include                                                                 
checking if UIC has KDE plugins available... no                                                                                        
configure: error:                                                                                                                      
you need to install kdelibs first.                                                                                                     

If you did install kdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile kdelibs. 
The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the  
_same Qt version_, compiled with the _same compiler_ and the same Qt
configuration settings.

Replies

Subject Author
Re: [gentoo-user] KDE3 apps installation fails... Volker Armin Hemmann <volkerarmin@××××××××××.com>