Gentoo Archives: gentoo-user

From: James Homuth <james@×××××××.com>
To: gentoo-user@l.g.o
Subject: RE: [gentoo-user] Updating a system....catch-22...
Date: Fri, 31 Oct 2008 13:14:04
Message-Id: 0af801c93b5a$858c2720$a500a8c0@quan
In Reply to: [gentoo-user] Updating a system....catch-22... by BRM
1 -----Original Message-----
2 From: BRM [mailto:bm_witness@×××××.com]
3 Sent: October 31, 2008 9:10 AM
4 To: Users Gentoo
5 Subject: [gentoo-user] Updating a system....catch-22...
6
7 I have a system that I'm just bringing back online after a few months down
8 due to hardware issues and lack of resources to get new hardware.
9
10 Some things are going okay - I got it past the e2fsprogs/e2fsprogs-lib
11 update fiasco (after hosing it and using GRML to get it back up).
12 However, I'm now stuck.
13
14 emerge world -vuDN won't complete because a package can't use "java-config",
15 complaining about python-updater needing to be run.
16 However, python-updater won't run because the of blocks due to software
17 being outdated and masked.
18
19 So it's a catch-22. I need to install a new java-config and other software
20 before I can get python-updater to run, but the emerge won't go through
21 without running python-updater for at least one package.
22
23 Any ideas on how to resolve?
24
25 TIA,
26
27 Ben
28
29
30 Try running python-updater for one package at a time and see what happens?
31 Once it gets past one or two it might not complain at you as much.