Gentoo Archives: gentoo-user

From: Arve Barsnes <arve.barsnes@×××××.com>
To: Gentoo <gentoo-user@l.g.o>
Cc: Steven Lembark <lembark@×××××××.com>
Subject: Re: [gentoo-user] emerge failes due to no valid source for pythonexec-2.2 when I have pythonexec-2.4 installed???
Date: Mon, 07 Feb 2022 07:27:05
1 On Mon, 7 Feb 2022 at 03:42, Steven Lembark <lembark@×××××××.com> wrote:
2 > # emerge --update --newuse --deep --with-bdeps=y @world
3 >
4 > emerge: there are no ebuilds to satisfy ">=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),-python_single_target_python2_7(-)]".
5 > (dependency required by "dev-python/ipaddress-1.0.23::gentoo" [installed])
6 > (dependency required by "@selected" [set])
7 > (dependency required by "@world" [argument])
8 >
9 >
10 > These are all python packages... is there no way to just sync
11 > the python version and be done with it?
13 Have you done a depclean regularly? This package,
14 dev-python/ipaddress, has appeared in at least half of all threads
15 where someone is having upgrade trouble with these python errors. This
16 package left the repo a long time ago, and simply does not exist any
17 more, and hence can also be depcleaned.
19 emerge --depclean --pretend to see if you have a long list of packages
20 that portage could remove.
22 Regards,
23 Arve