Gentoo Archives: gentoo-user

From: Daniel da Veiga <danieldaveiga@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] xorg.conf (HDMI vs DVI-D)
Date: Fri, 27 Aug 2010 20:06:30
Message-Id: AANLkTinEC10+FZiSsCD0zqYUFJsGuh1ErgMCHmmuNSeV@mail.gmail.com
In Reply to: [gentoo-user] xorg.conf (HDMI vs DVI-D) by James
1 On Fri, Aug 27, 2010 at 15:31, James <wireless@×××××××××××.com> wrote:
2 > Hello,
3 >
4 > We'll I've got a new samsung monitor 2333HD-1
5 > that is verified 1920x1080.
6 >
7 > Finally, I got it working on a dvi-d-2-dvi-d video cable
8 > with no problems...(minimal xorg.conf) and ati-drivers.
9 >
10 >
11 > OK, so I switch to a DVI-D<on video card> to HDMI
12 > on the monitor and it comes in, but the bottom and sides
13 > are missing.
14 >
15 > OK so I found this thread that I'm guessing is
16 > on the mark:
17 > http://www.phoronix.com/forums/showthread.php?t=23826
18 >
19 > But, I'm a little bit 'chicken' with xorg.conf, not
20 > to mention messing with the dot clock et al.......
21 > <CLUCK  CLUCK  CLUCK>
22 >
23 > Anyone want to venture a guess about the display settings,
24 > suggested in the link? that I should use? A better way?
25 >
26 > Here's the (example) math I use to use:
27 > #       DisplaySize 426 266
28 > # width  = (1680pix  / 100pix/in) x [25.4mm/in] =  427 --> 426
29 > # hieght = (1050pix  / 100pix/in) x [25.4mm/in] =  267 --> 266
30 >
31 >
32 > Here is what's working with the dvi-dvi cable:
33 >
34 > Section "Monitor"
35 >        Identifier   "aticonfig-Monitor[0]-0"
36 >        Option      "VendorName" "ATI Proprietary Driver"
37 >        Option      "ModelName" "Generic Autodetecting Monitor"
38 >        Option      "DPMS" "true"
39 >        HorizSync    30-81
40 >        VertRefresh  56-75
41 > EndSection
42 >
43 > Section "Device"
44 >        Identifier  "aticonfig-Device[0]-0"
45 >        Driver      "fglrx"
46 >        BusID       "PCI:2:0:0"
47 > #       Option      "XAANoOffscreenPixmaps" "true"
48 > EndSection
49 >
50 > Section "Screen"
51 >        Identifier "aticonfig-Screen[0]-0"
52 >        Device     "aticonfig-Device[0]-0"
53 >        Monitor    "aticonfig-Monitor[0]-0"
54 >        DefaultDepth     24
55 >        SubSection "Display"
56 >                Viewport  0 0
57 >                Depth     24
58 >                Modes    "1920x1080" "1680x1050" "1280x1024" "1024x768"
59 >        EndSubSection
60 > EndSection
61 >
62 >
63 >
64 >
65
66 Have you tried setting the INPUT NAME of the HDMI to "PC" using the
67 remote (on TV)?
68 My Samsung does the same, after I set my HDMI as "PC" everything is at
69 the right place.
70
71 --
72 Daniel da Veiga

Replies

Subject Author
[gentoo-user] Re: xorg.conf (HDMI vs DVI-D) James <wireless@×××××××××××.com>