Gentoo Archives: gentoo-user

From: Alexander Meyer <ali@×××××××××××××××.de>
To: gentoo-user@l.g.o
Subject: [gentoo-user] portage has blocking packages that are not installed
Date: Thu, 28 Jul 2005 11:31:56
Message-Id: 42E8C122.3090209@geschmeidomatik.de
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

hi list,

this probably isn't new but i didnt find any reference to it on the web
and in the mailing list archives, so i'd like to apologize in advance to
repost a possibly long answered question.

when i try to "emerge system --deep --newuse -upv" portage tells me this:

These are the packages that I would merge, in order:

<snip>
Calculating dependencies ...done!
[blocks B     ] <www-client/mozilla-firefox-1.0-r3 (is blocking
media-libs/freetype-2.1.9-r1)
[ebuild     U ] sys-libs/zlib-1.2.3 [1.2.2] -build 415 kB
[...]
<snap>

but when i then try to unmerge firefox ("emerge unmerge
mozilla-firefox") this is what i get:

<snip>
>>> These are the packages that I would unmerge:
www-client/mozilla-firefox selected: 1.0_pre-r2 protected: none omitted: none
>>> 'Selected' packages are slated for removal. >>> 'Protected' and 'omitted' packages will not be removed.
<snap> how can a package that is obviously not installed be blocking anything? and even more important: how do i resolve this issue? just unmerge the version of firefox that is installed? i'm not absolutely sure, but AFAIK this has happened before and just unmerging the installed version of the blocking program did not resolve the block on the not installed version. any help is appreciated! best regards, alexander -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.1 (GNU/Linux) iD8DBQFC6MEiw4sGV/pPyAwRApBDAJ99b+BiO0wjLMlX2Ef2z9TBjfGkegCfURf7 yLBMc9pSKgEGgscDN7J6pqI= =nyl5 -----END PGP SIGNATURE----- -- gentoo-user@g.o mailing list

Replies

Subject Author
Re: [gentoo-user] portage has blocking packages that are not installed Janne Johansson <jpjohans@×××××××××××.fi>