Gentoo Archives: gentoo-user

From: hw <hw@×××××.de>
To: gentoo-user@l.g.o
Subject: [gentoo-user] EAPI packages
Date: Wed, 10 Aug 2016 10:54:55
Message-Id: 57AB07ED.5080401@gc-24.de
Hi,

I´m trying to upgrade portage because I´m getting a message that it
needs to be able to work with EAPI 6 packages and can only do EAPI 5.

I´m running into merge conflicts when trying to update portage, and
apparently one of the packages (dev-python/cryptography) I could try
to update first to be able to update portage requires a version of
portage that can handle EAPI 6 packages.

How can upgrade portage?


emerge -a portage --newuse --update
[...]
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/install-xattr-0.5
[ebuild  N     ] dev-python/packaging-15.3-r2  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild     U  ] dev-python/setuptools-18.4 [7.0] PYTHON_TARGETS="python3_4* -python3_3* (-python3_5)"
[ebuild  N     ] dev-python/certifi-2015.11.20  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) -python3_3 (-python3_5)"
[ebuild  N     ] dev-python/pyxattr-0.5.5  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3 (-python3_5)"
[ebuild     U  ] sys-apps/portage-2.2.28 [2.2.14] USE="xattr*" PYTHON_TARGETS="python3_4* -python3_3* (-python3_5)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

   (dev-python/setuptools-18.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
     dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/certifi-2015.11.20:0/0::gentoo, ebuild scheduled for merge)

     dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)


   (dev-python/setuptools-7.0:0/0::gentoo, installed) pulled in by
     dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/cryptography-0.6.1:0/0::gentoo, installed)

     dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/chardet-2.2.1:0/0::gentoo, installed)


sys-apps/portage:0

   (sys-apps/portage-2.2.28:0/0::gentoo, ebuild scheduled for merge) pulled in by
     sys-apps/portage (Argument)

   (sys-apps/portage-2.2.14:0/0::gentoo, installed) pulled in by
     sys-apps/portage[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)

     sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-)] required by (app-admin/webapp-config-1.52-r1:0/0::gentoo, installed)
[...]
emerge -a dev-python/cryptography --newuse --update
[...]
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following update has been skipped due to unsatisfied dependencies:

dev-python/cryptography:0

!!! All ebuilds that could satisfy ">=dev-python/cffi-1.4.1:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-),python_targets_python3_3(-)?,-python_single_target_python3_3(-),python_targets_python3_4(-)?,-python_single_target_python3_4(-),python_targets_python3_5(-)?,-python_single_target_python3_5(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/cffi-1.7.0::gentoo (masked by: EAPI 6)
- dev-python/cffi-1.6.0::gentoo (masked by: EAPI 6)
- dev-python/cffi-1.5.2::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
[...]


I´m so tired of these stupid conflicts that come up every time I dare
trying to update ...  It makes it impossible to keep a Gentoo installation
up to date and seriously needs fixing.

Last time it was perl (on another machine), still unsolved, now it´s portage,
and I can´t even install freeradius because portage insists that it doesn´t
have use flags.

Replies

Subject Author
Re: [gentoo-user] EAPI packages Azamat Hackimov <azamat.hackimov@×××××.com>
Re: [gentoo-user] EAPI packages Neil Bothwick <neil@××××××××××.uk>
Re: [gentoo-user] EAPI packages Michael Orlitzky <mjo@g.o>
Re: [gentoo-user] EAPI packages "Andreas K. Hüttel" <dilfridge@g.o>
Re: [gentoo-user] EAPI packages james <garftd@×××××××.net>