Gentoo Archives: gentoo-user

From: Pandu Poluan <pandu@××××××.info>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Downgrading gcc
Date: Mon, 20 Feb 2012 04:39:29
Message-Id: CAA2qdGVpRg0Mwc8YPJQE3G-mfYQnsRQNNoRjS2Ms=n4FjXkvmQ@mail.gmail.com
In Reply to: [gentoo-user] Downgrading gcc by meino.cramer@gmx.de
1 Just re-emerge the older version e.g. emerge =...gcc-4.4.5 (... is the
2 category). Then use eselect gcc or gcc-config to select the active gcc
3 version.
4
5 CMIIW
6
7 Rgds,
8 On Feb 20, 2012 11:24 AM, <meino.cramer@×××.de> wrote:
9
10 > Hi,
11 >
12 > I want to downgrade gcc from 4.5.3-r1 to 4.4.5.
13 >
14 > The Gentoo gcc UPgrade guide tells me, that ABI are only upward
15 > compatible which implies problems when downgrading and not upgrading.
16 >
17 > Nonetheless a downgrade is needed here and I want to go
18 > to gcc-4.4.5.
19 >
20 > How can I acchieve this in a clean way?
21 >
22 > Best regards,
23 > mcc
24 >
25 >
26 >
27 >
28 >
29 >
30 >
31 >

Replies

Subject Author
[gentoo-user] Re: Downgrading gcc Nikos Chantziaras <realnc@×××××.de>