Gentoo Archives: gentoo-user

From: Dale <rdalek1967@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Trying to upgrade to KDE 4.5.1. FUBAR
Date: Tue, 07 Sep 2010 23:22:06
Message-Id: 4C86C8F5.5020702@gmail.com
Hi folks,

I think this is FUBAR in the most serious terms here.  What I did to 
screw this up.  I read somewhere that when you install KDE4 and remove 
KDE3, you can get rid of the qt3support USE flag.  Well, I had forgot 
about getting rid of that until I just happened to be looking at the USE 
line in make.conf for something else and saw it still there.  Well, I 
removed it and did a emerge -uvDNa world and let portage go for it.  It 
rebuilt quite a few packages then stopped with a failure.  That was a 
couple days ago.  I don't have that error anymore.  Well, after that 
went belly up I just added the flag back thinking I'll get back to where 
I was and figure it out later.  Let's just say portage doesn't like that 
either.

Where I am now.  I'm wanting to upgrade to KDE 4.5.1 and was sort of 
doing all the above and this at once.  Right now, I'm getting a WHOLE 
LOT of these sort of errors:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

   (x11-libs/qt-script-4.6.3, installed) pulled in by
     ~x11-libs/qt-script-4.6.3aqua=,debug=] required by 
(x11-libs/qt-gui-4.6.3, installed)
 >=x11-libs/qt-script-4.6.3:4 required by 
(kde-base/plasma-workspace-4.5.1, ebuild scheduled for merge)
     (and 13 more with the same problems)

   (x11-libs/qt-script-4.6.2, ebuild scheduled for merge) pulled in by
     ~x11-libs/qt-script-4.6.2aqua=,debug=] required by 
(x11-libs/qt-gui-4.6.2, ebuild scheduled for merge)

x11-libs/qt-svg:4

   (x11-libs/qt-svg-4.6.2, ebuild scheduled for merge) pulled in by
     (no parents that aren't satisfied by other packages in this slot)

   (x11-libs/qt-svg-4.6.3, installed) pulled in by
 >=x11-libs/qt-svg-4.6.34 required by (kde-base/mplayerthumbs-4.5.1, 
ebuild scheduled for merge)
     (and 13 more with the same problem)

x11-libs/qt-xmlpatterns:4

   (x11-libs/qt-xmlpatterns-4.6.2, ebuild scheduled for merge) pulled in by
     ~x11-libs/qt-xmlpatterns-4.6.2aqua=,debug=] required by 
(x11-libs/qt-webkit-4.6.2-r1, ebuild scheduled for merge)

   (x11-libs/qt-xmlpatterns-4.6.3, installed) pulled in by
     ~x11-libs/qt-xmlpatterns-4.6.3aqua=,debug=] required by 
(x11-libs/qt-webkit-4.6.3-r1, installed)


I only posted here a SMALL portion of this.  Can someone explain, in a 
way that I can understand, how to get past these?  I have never been 
able to make much sense of these things.  They seem to always be bass 
ackwards of what makes sense to me.  Just pick one and explain what 
portage is trying to tell me so I can fix the others one by one, 
hopefully anyway.

I get that I need to unmerge something so that it can emerge a new 
version.  I just can't figure out what is what.

Thanks in advance for anyone that can help me have a light bulb 
moment.   O_O

Dale

:-)  :-)

Replies

Subject Author
Re: [gentoo-user] Trying to upgrade to KDE 4.5.1. FUBAR Alan McKinnon <alan.mckinnon@×××××.com>