Gentoo Archives: gentoo-user

From: Dale <rdalek1967@×××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] eject and util-linux blocker
Date: Mon, 16 Mar 2015 14:08:50
Message-Id: 5506E3E8.8070008@gmail.com
Howdy,

I did some googling and a search on the forums on this.  It seems eject
is part of util-linux now but something just won't let me get past this
blocker.  Here is what I get, after updating everything else by hand:

root@fireball / # emerge -uvaDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-block/eject-2.1.5-r2::gentoo  USE="nls" 121 KiB
[ebuild     UD ] sys-apps/util-linux-2.24.1-r3::gentoo [2.26.1::gentoo]
USE="bash-completion%* cramfs ncurses nls pam static-libs* suid udev
unicode -caps -cytune% -fdformat -python (-selinux) -slang {-test}
-tty-helpers (-systemd%)" ABI_X86="(64) (-32) (-x32)"
PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4"
PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[blocks B      ] sys-block/eject ("sys-block/eject" is blocking
sys-apps/util-linux-2.24.1-r3)

Total: 2 packages (1 downgrade, 1 new), Size of downloads: 121 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-block/eject-2.1.5-r2:0/0::gentoo, ebuild scheduled for merge)
pulled in by
    sys-block/eject required by (virtual/eject-0:0/0::gentoo, installed)

  (sys-apps/util-linux-2.24.1-r3:0/0::gentoo, ebuild scheduled for
merge) pulled in by
    >=sys-apps/util-linux-2.13 required by
(www-plugins/nspluginwrapper-1.4.4-r3:0/0::gentoo, installed)
    <sys-apps/util-linux-2.25[static-libs] required by
(sys-fs/lvm2-2.02.109:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.13 required by
(sys-power/pm-utils-1.4.1-r6:0/0::gentoo, installed)
   
>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]
(>=sys-apps/util-linux-2.24.1-r3[abi_x86_64(-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed) >=sys-apps/util-linux-2.20 required by (sys-fs/eudev-2.1.1:0/0::gentoo, installed) >=sys-apps/util-linux-2.21 required by (sys-kernel/dracut-041:0/0::gentoo, installed) >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-2.1.3:2/2::gentoo, installed) sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed)
>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]
(>=sys-apps/util-linux-2.24.1-r3[abi_x86_64(-)]) required by (net-libs/gupnp-0.20.13:0/4::gentoo, installed) sys-apps/util-linux required by (sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed) >=sys-apps/util-linux-2.16 required by (sys-fs/mdadm-3.3.1-r2:0/0::gentoo, installed) >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.12:0/0::gentoo, installed) sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, installed) sys-apps/util-linux required by (app-text/rarian-0.8.1-r2:0/0::gentoo, installed) >=sys-apps/util-linux-2.19 required by (dev-libs/rasqal-0.9.29:0/0::gentoo, installed) >=sys-apps/util-linux-2.20 required by (sys-block/gparted-0.21.0:0/0::gentoo, installed) sys-apps/util-linux required by @system >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.109:0/0::gentoo, installed) >=sys-apps/util-linux-2.22 required by (virtual/eject-0:0/0::gentoo, installed) For more information about Blocked Packages, please refer to the following section of the Gentoo Linux x86 Handbook (architecture is irrelevant): https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages root@fireball / # I've tried a few things to get past it, keywording newer versions etc but still no change. It seems to be seriously wanting to downgrade util-linux no matter what I do too. Anyone run into this and find a way past it? Any clues? Thanks Dale :-) :-)

Replies

Subject Author
Re: [gentoo-user] eject and util-linux blocker Walter Dnes <waltdnes@××××××××.org>