Gentoo Archives: gentoo-user

From: Jack <ostroffjh@×××××××××××××××××.net>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] wireplumper for pipewire 0.3.39 startup problems
Date: Sat, 06 Nov 2021 22:54:58
Message-Id: PP2R5QEZ.JLP55EEA.OOFUN23U@DX5KYFJX.CKQPHUPR.JEPHO2PU
In Reply to: [gentoo-user] wireplumper for pipewire 0.3.39 startup problems by Tamer Higazi
1 On 2021.11.06 18:00, Tamer Higazi wrote:
2 > Hi people,
3 >
4 > I got a problem getting "wireplumper" for pipewire to run.
5 >
6 > tamer@tux ~ $ systemctl --user status wireplumber.service
7 >
8 > tells me that it failed to start
9 >
10 > × wireplumber.service - Multimedia Service Session Manager
11 >      Loaded: loaded (/usr/lib/systemd/user/wireplumber.service;
12 > enabled; vendor preset: enabled)
13 >      Active: failed (Result: exit-code) since Sat 2021-11-06 22:46:02
14 > CET; 2min 53s ago
15 >     Process: 1380 ExecStart=/usr/bin/wireplumber (code=exited,
16 > status=70)
17 >    Main PID: 1380 (code=exited, status=70)
18 >
19 > Nov 06 22:46:02 tux systemd[1244]: wireplumber.service: Failed with
20 > result 'exit-code'.
21 > Nov 06 22:46:02 tux systemd[1244]: wireplumber.service: Scheduled
22 > restart job, restart counter is at 5.
23 > Nov 06 22:46:02 tux systemd[1244]: Stopped Multimedia Service Session
24 > Manager.
25 > Nov 06 22:46:02 tux systemd[1244]: wireplumber.service: Start request
26 > repeated too quickly.
27 > Nov 06 22:46:02 tux systemd[1244]: wireplumber.service: Failed with
28 > result 'exit-code'.
29 > Nov 06 22:46:02 tux systemd[1244]: Failed to start Multimedia Service
30 > Session Manager.
31 >
32 > Executing "wireplumper" gives out an error that it failed to start
33 > "wireplumper":
34 >
35 > tamer@tux ~ $ /usr/bin/wireplumber
36 > failed to start systemd logind monitor: -2 (No such file or directory)
37 > M 22:46:16.429961        wireplumber
38 > ../wireplumber-0.4.4/src/main.c:328:on_disconnected: disconnected
39 > from pipewire
40 >
41 >
42 > by the way, according the pipewire gentoo guide, the ~/.xinitrc file
43 > should look like this:
44 >
45 > if which dbus-launch >/dev/null && test -z
46 > "$DBUS_SESSION_BUS_ADDRESS"; then
47 >        eval `dbus-launch --sh-syntax --exit-with-session`
48 > fi
49 >
50 > /usr/bin/gentoo-pipewire-launcher
51 >
52 > ...but "/usr/bin/gentoo-pipewire-launcher" simply does not exist ...
53 >
54 >
55 > pipewire is on 0.3.39:
56 >
57 > tamer@tux ~ $ LANG=C pactl info | grep "Server Name"
58 > Server Name: PulseAudio (on PipeWire 0.3.39)
59 >
60 >
61 > emerge --info:
62 > https://pastebin.com/raw/Ya6LmipC
63 >
64 > (emerge -uDN @world) had been executed today ....
65
66 Your post has a mix of "wireplumper" and "wireplumber". Hopefully
67 there is just a repeated typo, and in fact, all should be the same?

Replies

Subject Author
Re: [gentoo-user] wireplumber for pipewire 0.3.39 startup problems Tamer Higazi <th982a@××××××××××.com>