Gentoo Archives: gentoo-user

From: Dale <rdalek1967@×××××.com>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] problem emerging util-linux
Date: Sat, 27 Feb 2010 22:38:57
Message-Id: 4B899EE9.7060007@gmail.com
In Reply to: [gentoo-user] problem emerging util-linux by linux@gabriel-striewe.de
chrome://messenger/locale/messengercompose/composeMsgs.properties:
> > Hi, > > I am using gentoo since one month. Today I tried an emerge --update system after an emerge --sync. > However, I got an error emerging util-linux. > > I am using a custom compiled vanilla kernel from kernel.org. uname -a says: > > Linux laptop 2.6.32.8 #4 SMP PREEMPT Sat Feb 27 04:25:19 CET 2010 i686 Intel(R) Celeron(R) M processor > 1.70GHz GenuineIntel GNU/Linux > > > Here is the output of > > > ################################# > emerge --pv: > > [ebuild N ] sys-apps/util-linux-2.17-r1 USE="crypt nls perl unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" > > and the emerge log: > > fallocate.o: In function `main': > fallocate.c:(.text+0x39f): undefined reference to `fallocate64' > collect2: ld returned 1 exit status > make[2]: *** [fallocate] Error 1 > make[2]: *** Waiting for unfinished jobs.... > make[2]: Leaving directory `/var/tmp/portage/sys-apps/util-linux-2.17-r1/work/util-linux-ng-2.17/sys-utils' > make[1]: *** [all-recursive] Error 1 > make[1]: Leaving directory `/var/tmp/portage/sys-apps/util-linux-2.17-r1/work/util-linux-ng-2.17' > make: *** [all] Error 2 > * ERROR: sys-apps/util-linux-2.17-r1 failed: > * emake failed > * > * Call stack: > * ebuild.sh, line 54: Called src_compile > * environment, line 2647: Called _eapi2_src_compile > * ebuild.sh, line 646: Called die > * The specific snippet of code: > * emake || die "emake failed" > * > * If you need support, post the output of 'emerge --info =sys-apps/util-linux-2.17-r1', > * the complete build log and the output of 'emerge -pqv =sys-apps/util-linux-2.17-r1'. > * The complete build log is located at '/var/tmp/portage/sys-apps/util-linux-2.17-r1/temp/build.log'. > * The ebuild environment file is located at '/var/tmp/portage/sys-apps/util-linux-2.17-r1/temp/environment'. > * S: '/var/tmp/portage/sys-apps/util-linux-2.17-r1/work/util-linux-ng-2.17' > > Any ideas. I am fairly new to gentoo, have used it a few years ago, in the meantime using debian and fedora, but I came > back to it. > > Thanks, > > Gabriel > >
upgrade to =sys-libs/glibc-2.11-r1 http://bugs.gentoo.org/show_bug.cgi?id=300307 Hope that helps. Dale :-) :-)