Gentoo Archives: gentoo-user

From: Albert Hopkins <marduk@g.o>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] profile upgrade from 2005.1 to 2006.1
Date: Tue, 13 Mar 2007 15:47:28
Message-Id: 1173800499.2041.8.camel@blackwidow.nbk
In Reply to: [gentoo-user] profile upgrade from 2005.1 to 2006.1 by "de Almeida
1 On Tue, 2007-03-13 at 11:22 -0400, de Almeida, Valmor F. wrote:
2
3 >
4 > ************************************
5 > These are the packages that would be merged, in order:
6 >
7 > Calculating system dependencies
8 > Parse Error reading PROVIDE and USE in
9 > '/var/db/pkg/x11-base/xorg-x11-6.8.2-r4'
10 > Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl?
11 > virtual/glu virtual/xft'
12 > Exception: Conditional without parenthesis: 'opengl?'
13 > *************************************
14 >
15
16 In all likelihood that particular package used a format which is for
17 whatever reasons is no longer valid. I would simply unmerge the package
18 and either manually merge a version that now exists in portage or
19 continue your update and it will likely get pulled in as a dependency.
20
21 > Is this related to the current modular use of X11? Later in the output
22 > of system packages to be updated I get:
23 >
24 > ******************************
25 > [blocks B ] (is blocking
26 > x11-proto/inputproto-1.3.2, x11-proto/xf86bigfontproto-1.1.2,
27 > x11-proto/xextproto-7.0.2, x11-libs/libXext-1.0.1,
28 > x11-proto/xcmiscproto-1.1.2, x11-misc/util-macros-1.1.0,
29 > x11-libs/xtrans-1.0.1, x11-apps/xauth-1.0.1, x11-libs/libXau-1.0.2,
30 > x11-libs/libXmu-1.0.2, x11-proto/kbproto-1.0.3, x11-libs/libSM-1.0.1,
31 > x11-libs/libXdmcp-1.0.1, x11-libs/libICE-1.0.1, x11-libs/libXt-1.0.2,
32 > x11-proto/xproto-7.0.7, x11-proto/bigreqsproto-1.0.2,
33 > x11-libs/libX11-1.0.3)
34 > ******************************
35 >
36 > Should I clean out my old X? which is x11-base/xorg-x11-6.8.2-r4 and not
37 > x11-base/xorg-x11-6.9 as in the blocking message above. Also, according
38 > to emerge --search the latest version available for x11-base/xorg-x11 is
39 > 7.1.
40
41 Best practice when dealing with blocks: unmerge the package(s) which is
42 blocking (in your case <=x11-base/xorg-x11-6.9), then continue where you
43 left off before. Continue as necessary.
44
45
46 --
47 Albert W. Hopkins
48
49 --
50 gentoo-user@g.o mailing list

Replies