Gentoo Archives: gentoo-user

From: Dan Johansson <Dan.Johansson@×××.nu>
To: gentoo-user@l.g.o
Subject: [gentoo-user] emerge --update --deep --verbose --newuse world --pretend "misses" package to update
Date: Wed, 20 Jun 2007 17:27:28
Message-Id: 200706201920.55649.Dan.Johansson@dmj.nu
Today when I did an emerge --update --deep --verbose --newuse world --pretend 
I gott the following list back:

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] sys-fs/cryptsetup-luks-1.0.4-r3 [1.0.3-r2] 
USE="nls -build% -dynamic (-selinux)" 0 kB
[ebuild     U ] dev-java/xml-commons-external-1.3.04 [1.3.02-r1] 
USE="-doc -source" 0 kB
[ebuild     U ] dev-java/xml-commons-resolver-1.2 [1.1-r1] USE="-doc -source" 
0 kB


For some reason a also did an eix-test-obsolete before really doing the update 
and this is what I got:

...
Installed packages with a version not in the database (or masked):

[U] x11-misc/icon-naming-utils (0.8.1@12/11/06 -> 0.8.2): Utilities to help 
with the transition to the new freedesktop.org naming scheme, they will ma


If I do an emerge x11-misc/icon-naming-utils --verbose --pretend I get
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-misc/icon-naming-utils-0.8.2 [0.8.1] 65 kB

Why does not --update world include this package?

Regards,
-- 
Dan Johansson, <http://www.dmj.nu>
***************************************************
This message is printed on 100% recycled electrons!
***************************************************

Replies