Gentoo Archives: gentoo-user

From: Arnau Bria <arnau@×××××××××.net>
To: gentoo-user@l.g.o
Subject: [gentoo-user] problems updating system
Date: Mon, 16 Feb 2009 08:40:49
Message-Id: 20090216094053.49dd764c@lx-arnau.pic.es
Hi all,

I'm trying to upgrade my system and I found this problem:
# emerge -uD world
Calculating world dependencies /
!!! All ebuilds that could satisfy ">=sys-libs/e2fsprogs-libs-1.41" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/e2fsprogs-libs-1.41.3-r1 (masked by: required EAPI 2, supported EAPI 1)
- sys-libs/e2fsprogs-libs-1.41.4 (masked by: required EAPI 2, supported EAPI 1)


**What EAPI means?

I'm on portage 2.1.3.19, and I've read that I should upgrade portage to
2.1.6 (minimum) and then my error will disappear, but when trying to
upgrade portage I find:

i686-pc-linux-gnu-gcc -o .libs/setfattr -Wl,-O1 -Wl,-O1 -Wl,-O1 setfattr.o  ../libmisc/.libs/libmisc.a ../libattr/.libs/libattr.so 
creating setfattr
=== examples ===
gmake[1]: Nothing to be done for `default'.
=== test ===
gmake[1]: Nothing to be done for `default'.
=== m4 ===
gmake[1]: Nothing to be done for `default'.
=== man ===
=== man1 ===
gmake[2]: Nothing to be done for `default'.
=== man2 ===
gmake[2]: Nothing to be done for `default'.
=== man3 ===
gmake[2]: Nothing to be done for `default'.
=== man5 ===
gmake[2]: Nothing to be done for `default'.
=== doc ===
/bin/gzip --best -c < CHANGES > CHANGES.gz
=== po ===
/usr/bin/xgettext --language=C --keyword=_ -o attr.pot ../attr/attr.c ../getfattr/getfattr.c ../setfattr/setfattr.c ../libattr/attr_copy_fd.c ../libattr/attr_copy_file.c
/usr/bin/xgettext: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
gmake[1]: *** [attr.pot] Error 127
make: *** [default] Error 2
 * 
 * ERROR: sys-apps/attr-2.4.41 failed.
 * Call stack:
 *            ebuild.sh, line 1701:  Called dyn_compile
 *            ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *            ebuild.sh, line   44:  Called src_compile
 *   attr-2.4.41.ebuild, line   50:  Called die
 * The specific snippet of code:
 *   	emake || die
 *  The die message:
 *   (no error message)

# ls -lsa /usr/lib/libexpat.*
160 -rw-r--r-- 1 root root 157620 Feb 16 09:26 /usr/lib/libexpat.a
  4 -rw-r--r-- 1 root root    793 Feb 16 09:26 /usr/lib/libexpat.la
  0 lrwxrwxrwx 1 root root     17 Feb 16 09:26 /usr/lib/libexpat.so -> libexpat.so.1.5.2
  0 lrwxrwxrwx 1 root root     17 Feb 16 09:26 /usr/lib/libexpat.so.1 -> libexpat.so.1.5.2
136 -rwxr-xr-x 1 root root 132396 Feb 16 09:26 /usr/lib/libexpat.so.1.5.2

I've tried to rebuild expat, but did not solve my problem...

Anyopne knows what's happening in my system?

# emerge --info
Portage 2.1.3.19 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 i686)
=================================================================
System uname: 2.6.21-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Timestamp of tree: Fri, 13 Feb 2009 08:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r4, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://lx-arnau.pic.es/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog jpeg jpg midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session slang spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewr
 ite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


-- 
Arnau Bria
http://blog.emergetux.net
Bombing for peace is like fucking for virginity

Replies

Subject Author
Re: [gentoo-user] problems updating system Stroller <stroller@××××××××××××××××××.uk>
Re: [gentoo-user] problems updating system Neil Bothwick <neil@××××××××××.uk>
Re: [gentoo-user] problems updating system Crob <crobzhu@×××××.com>