Gentoo Archives: gentoo-user

From: Petric Frank <pfrank@×××.de>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] Problem executing pgAdmin4
Date: Wed, 07 Nov 2018 15:57:18
Message-Id: 3773074.2eBRju3bLs@main
In Reply to: Re: [gentoo-user] Problem executing pgAdmin4 by Jack
Am Dienstag, 6. November 2018, 21:24:37 CET schrieb Jack:
> On 2018.11.06 00:19, Petric Frank wrote: > > Am Dienstag, 6. November 2018, 01:00:04 CET schrieb Jack: > > > On 2018.11.05 14:21, Petric Frank wrote: > >>> pgadmin3 is masked now. So i installed pgadmin4 (current stable > >>> verion 3.0). Installed w/o problems. > >>> > > > > But when executing it (in a terminal window) i get a dialog box > > > > saying > > > > > > An error occurred initialising the application server: > > > > An error occurred initialising the application server: > > > > %1 > > > > > > > > and the terminal window is filled pagewise with > > > > ----------------------- cut --------------------------- > > > > Python path: "/usr/lib64/python3.6/site-packages" > > > > Python Home: "" > > > > Webapp path: "/usr/share/pgadmin4/web/pgAdmin4.py" > > > > "Failed to launch the application server, server thread exiting. > > > > \u0000➑\u0000\u0000\u0000榠\u1C93翱\u0000먀ᰆ翱 > > > > \u0000\u0000\u0000\u0000\u0000\u0000\u0000\u0000\u0000\u000F\u0000\u0000\u > > > > > > 0000$ > > > > \u09FF-&Ͽ\uFFFF\u0005\u0A0E+(\u07FE\uFFFF\uFFFF"\uFFFF,攍兇须꾭懰䀌翱\u0000\uEAB > > > > > > 0ᜊ翱 > > > > \u0000㙔\uE4C8帚꿧\u0000\u0000\u0000\u0000\u0000\u0000\u0000\u0000盚饇䥟璊Ꙑ䀌翱 > > > > \u0000\uA8C8ᜉ翱\u0000鯩슄鼗䷷\u0E70䀋翱\u0000偈䀌翱\u0000✠徰⼬蘉좸⠪翱\u0000ꃘᜋ翱\u0000ⷬ행膀ꈋ > > > > > > ꈨ䀌翱 > > > > \u0000垀ᜋ翱\u0000沦⻋䎛緒짐⠪翱\u0000嚠ᜋ翱\u0000段ꉀꒅ텣遰⠤翱\u0000撈ᜋ翱\u0000⻲幕炈멕胰䀌翱\u0000攐 > > > > > > ᜋ翱 > > > > \u0000\uE6A3ᓐ溪껊쫨⠪翱\u0000斘ᜋ翱\u0000\uF42F끒䙭㔋昰䀌翱\u0000映ᜋ翱\u0000盰\uE66A⍷캪限ᮑ翱\ > > > > > > u0000 > > > > 좸ᜊ翱\u0000뱾ס⏤鱑룰⠁翱\u0000춸ᜊ翱\u0000ꢦ蔞蠹꾞㨈䀐翱\u0000츈ᜊ翱\u0000\uF20E㥑䶫텓움⡌翱\u0000饠\ > > > > > > u1CBB ... > > > > ----------------------- cut --------------------------- > > > > > > > > Selecting "Ok " in the dialog box i get an other tabbed dialog box > > > > asking for > > > > a browser command (currently empty) and Python paths (preset > > > > values > > > > > > seem ok). > > > > > > > > Entering "/usr/bin/firefox %URL%" as browser command does not > > > > change > > > > > > anything. > > > > > > > > Any hints ? > > > > > > > > Info: > > > > Kernel 4.14.65 (Gentoo) > > > > KDE Plasma (kde-plasma/plasma-meta-5.13.5) > > > > Memory 16 G > > > > Apache installed but not running > > > > Browsers konqueror and firefox available > > > > pgadmin3 still installed > > > > Python 2.7, 3.6 and 3.5 installed (= "eselect python list" > > > > output) > > > > > > regards > > > > > > > > Petric > > > > > > Interesting. I only get > > > ------------- > > > Python path: "/usr/lib64/python3.6/site-packages" > > > Python Home: "" > > > Webapp path: "/usr/share/pgadmin4/web/pgAdmin4.py" > > > ------------ > >> > >> And then a popup that says "The application server could not be > >> contacted." > >> > >> This is with eselect postgresql set to either 9.6 or 10. Also - all > >> above running as myself, although I get the same results with root > >> or postgres. It looks like although I have 10 installed, I never > >> initialized it, although 9.6 should work OK. > >> > >> I'm now emerging the test version of pgAdmin4 to see if it makes any > >> difference. > >> > > > Jack > > > > Hello Jack, > > > > if i remove the .pgadmin directory in my home i get - after a long > > wait a dialog box saying The application server could not be > > contacted. > > > > In the terminal it prints: > > -------------------------- cut ------------------------------ > > Python path: "/usr/lib64/python3.6/site-packages" > > Python Home: "" > > Webapp path: "/usr/share/pgadmin4/web/pgAdmin4.py" > > NOTE: Configuring authentication for DESKTOP mode. > > -------------------------- cut ------------------------------ > > > > Starting pgAdmin4 again i get the output and dialogs i wrote > > initially in this thread. > > I installed pgadmin4-3.4-r1 and it works. 3.5 has been released > (https://www.pgadmin.org/) so I filed a version bump request > (https://bugs.gentoo.org/670556).
I will try the upgrade. For documentation purposes i got version 3.0 running using this guide: 1. install dev-python/backports and dev-python/backports-csv (masked !) 2. extend file /usr/share/pgadmin4/web/config_local.py to contain: import os DATA_DIR = os.path.realpath(os.path.expanduser(u'~/.pgadmin/')) LOG_FILE = os.path.join(DATA_DIR, 'pgadmin4.log') SQLITE_PATH = os.path.join(DATA_DIR, 'pgadmin4.db') SESSION_DB_PATH = os.path.join(DATA_DIR, 'sessions') STORAGE_DIR = os.path.join(DATA_DIR, 'storage') SERVER_MODE = False UPGRADE_CHECK_ENABLED = False 3. start python /usr/share/pgadmin4/web/pgAdmin4.py 4. point your browser to localhost:5050 Hope that helps someone ... regards Petric

Replies

Subject Author
Re: [gentoo-user] Problem executing pgAdmin4 Jack <ostroffjh@×××××××××××××××××.net>