Gentoo Archives: gentoo-user

From: Francisco Ares <frares@×××××.com>
To: gentoo-user <gentoo-user@l.g.o>
Subject: [gentoo-user] How to correctly handle multiple Qt versions (qt4 X qt5)
Date: Mon, 01 Aug 2016 12:18:12
Message-Id: CAHH9eM65gqENMUtcY4k_axcd9QraVEh=JxpfF4vtnHwYspehLA@mail.gmail.com
Hi all.

In thys Gento system, there are packages that still need Qt-4, while newest
KDE, for instance, needs Qt-5.

Even inserting entries in "/etc/portage/package.use" for the packages that
need qt4, the emerge still fails, arguing that the package needs Qt-4.

On this system, "qtchooser" has never worked propperly - as far as I could
understand it - so I'm used to manage the "default.conf" symlink at
"/etc/xdg/qtchooser/" - is it correct to do so?  If not, what should I do?

Thanks!
Francisco

Replies

Subject Author
Re: [gentoo-user] How to correctly handle multiple Qt versions (qt4 X qt5) Fernando Rodriguez <cyklonite@×××××.com>