Gentoo Archives: gentoo-user

From: Harry Putnam <reader@×××××××.com>
To: gentoo-user@l.g.o
Subject: [gentoo-user] virtualBox and Gcc
Date: Fri, 20 Feb 2009 18:59:12
Message-Id: 877i3l0wfm.fsf@newsguy.com
Can anyone tell me if there is some way to tell emerge to use a
specific compiler during an emerge?

I get this output during emerge of virutalbox-ose.  Note that it says
to use a version of gcc earlier than 4.3.  Is there some way to do
that without causing grief somewhere else?

[...]
 VirtualBox-2.0.6-OSE.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...          [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> cfg-update-1.8.2-r1: Creating checksum index...
* there are known problems with gcc 4.3 and the virtualbox * recompiler stuff. Please use at least a version of gcc < 4.3 * * ERROR: app-emulation/virtualbox-ose-2.0.6 failed. * Call stack: * ebuild.sh, line 49: Called pkg_setup * virtualbox-ose-2.0.6.ebuild, line 54: Called die * The specific snippet of code: * die "gcc 4.3 cannot build the virtualbox recompiler" * The die message: * gcc 4.3 cannot build the virtualbox recompiler [...]

Replies

Subject Author
Re: [gentoo-user] virtualBox and Gcc Paul Hartman <paul.hartman+gentoo@×××××.com>