Gentoo Archives: gentoo-user

From: Philip Webb <purslow@××××××××.net>
To: Gentoo User <gentoo-user@l.g.o>
Subject: [gentoo-user] problem dropping Python 2.7
Date: Thu, 12 Sep 2019 04:36:22
I've been trying to eliminate Python 2.7
& have dropped the 'TARGETS' lines from 'make.conf', leaving only 3.6 ,
but it seems that a number of pkgs still require it :

  root:762 ~> emerge -cpv python:2.7
  Calculating dependencies... done!
  dev-lang/python-2.7.15 pulled in by:
    dev-lang/spidermonkey-60.5.2_p0-r2 requires >=dev-lang/python-2.7.5-r2:2.7[ncurses,sqlite,ssl,threads]
    dev-lang/yasm-1.3.0 requires >=dev-lang/python-2.7.5-r2:2.7
    dev-libs/libxml2-2.9.9-r1 requires >=dev-lang/python-2.7.5-r2:2.7[xml]
    dev-libs/libxslt-1.1.33-r1 requires >=dev-lang/python-2.7.5-r2:2.7[xml]
    dev-python/enum34-1.1.6-r1 requires >=dev-lang/python-2.7.5-r2:2.7
    dev-qt/qtwebkit-5.212.0_pre20180120 requires >=dev-lang/python-2.7.5-r2:2.7
    dev-util/boost-build-1.65.0 requires >=dev-lang/python-2.7.5-r2:2.7
    net-mail/fetchmail-6.3.26-r4 requires >=dev-lang/python-2.7.5-r2:2.7[tk]
    net-print/cups-2.2.12 requires >=dev-lang/python-2.7.5-r2:2.7
    sys-devel/llvm-7.1.0 requires >=dev-lang/python-2.7.5-r2:2.7
    www-client/firefox-60.8.0 requires dev-lang/python:2.7[ncurses,sqlite,ssl,threads(+)]
  >>> No packages selected for removal by depclean

I've already remerged 'firefox' + 'spidermonkey' with the new 'make.conf',
but they still appear above.

When I check via 'eix --installed-with-use python_targets_python2_7',
it lists  8  pkgs :

  python-exec yasm libxml2 libxslt enum34 boost-build fetchmail cups

When I try to remerge eg 'libxslt', I'm told :

  root:767 ~> emerge -pv libxslt
  These are the packages that would be merged, in order:
  Calculating dependencies |
  !!! Problem resolving dependencies for dev-libs/libxslt
  ... done!
  !!! The ebuild selected to satisfy "libxslt" has unmet requirements.
  - dev-libs/libxslt-1.1.33-r1::gentoo USE="crypt -debug -examples python -static-libs" ABI_X86="-32 (64) (-x32)" PYTHON_TARGETS="-python2_7"
  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( python_targets_python2_7 )
  The above constraints are a subset of the following complete expression:
    python? ( any-of ( python_targets_python2_7 ) )

'libxslt-1.1.33-r1.ebuild' does in fact say "PYTHON_COMPAT=( python2_7 )".

Can anyone suggest a solution ?

SUPPORT     ___________//___,   Philip Webb
ELECTRIC   /] [] [] [] [] []|   Cities Centre, University of Toronto
TRANSIT    `-O----------O---'   purslowatchassdotutorontodotca


Subject Author
[gentoo-user] Re: problem dropping Python 2.7 Nikos Chantziaras <realnc@×××××.com>