Gentoo Archives: gentoo-user

From: Neil Bothwick <neil@××××××××××.uk>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] eselect python cleanup
Date: Sun, 24 Mar 2019 22:23:58
Message-Id: 20190324222340.7a31d3e0@digimed.co.uk
In Reply to: Re: [gentoo-user] eselect python cleanup by allan gottlieb
1 On Sun, 24 Mar 2019 17:04:25 -0400, allan gottlieb wrote:
2
3 > >> > Am I correct in believing that I should now execute
4 > >> > eselect python cleanup
5 > >
6 > >> I just ran into the same problem, and that solution seems to have
7 > >> worked for me.
8 > >
9 > > It worked for me, but only after I ran it twice. This was
10 > > reproducible on several systems.
11 >
12 > It worked for me running only once on each of two systems.
13 > By worked I mean the error msg
14 >
15 > python-exec: Invalid impl in /etc/python-exec/python-exec.conf:
16 > python3.4
17 >
18 > stopped appearing on my "emerge update world" commands. Perhaps you
19 > Neil tested further for failure and Jack and I should as well.
20
21 No, I tested exactly the same:
22
23 emerge world gives warning
24 run eselect python cleanup
25 emerge world gives warning
26 run eselect python cleanup
27 emerge world gives no warning
28
29 I should have examined /etc/python-exec/python-exec.conf beforehand,
30 maybe it included two mentions of python3.4.
31
32
33 --
34 Neil Bothwick
35
36 When puns are outlawed only outlaws will have puns.

Replies

Subject Author
Re: [gentoo-user] eselect python cleanup Mick <michaelkintzios@×××××.com>