Gentoo Archives: gentoo-user

From: Meino.Cramer@×××.de
To: Gentoo <gentoo-user@l.g.o>
Subject: [gentoo-user] Porblems with nvidia-settings vs. nvidia-drivers: Up-/downgrade race condition
Date: Sat, 17 Oct 2015 11:08:02
Message-Id: 20151017110743.GA4646@solfire
Hi,

previously I had emerged nvidia-settings seperately. This leads to an 
problem with a recent update, because the nvidia-settings were
pulling in the old version of the nvidia-drivers and the update wants
the new version of the drivers.

So I emerge -C'ed the nvidia-settings, set the USE-flag 'tools' for
the drivers and updated...it works.

This morning ... updateing my Gentoo box again, the same scenario
happens again...nvidia-settings (old version) were missing (why?)
and again wants the old driver while emerge wants the new one.

How can I get out of this?

Best regards,
Meino

Replies