Gentoo Archives: gentoo-user

From: Arve Barsnes <arve.barsnes@×××××.com>
To: Gentoo <gentoo-user@l.g.o>
Subject: Re: [gentoo-user] Re: How to diagnose version conflicts?
Date: Wed, 12 Jan 2022 06:30:29
In Reply to: [gentoo-user] Re: How to diagnose version conflicts? by Grant Edwards
1 On Wed, 12 Jan 2022 at 01:44, Grant Edwards <grant.b.edwards@×××××.com> wrote:
2 > Still not sure what command one uses to determine what package is
3 > preventing some other package from being upgraded...
5 It should all be in the emerge output, although it's quite hard to read.
7 If you want help interpreting it you could post the complete conflict
8 output, but what you've posted in your initial message is just the bit
9 that says that python-exec-2.4.8 requires python-exec-conf-2.4.6.
10 That's not a conflict, that's just one of the packages having one
11 dependency. To have a conflict, a different package would need to
12 require a different version.
14 Most of the times this particular kind of conflict is with an older
15 package that requires older PYTHON_TARGETS than can be provided, and I
16 expect something that got depcleaned with ipkg-utils, or ipkg-utils
17 directly, required python-exec or python-exec-conf with
18 PYTHON_TARGETS="python3_7". Note that dev-lang/python itself is not
19 the source of any of these problems, I still have python 2.7 and 3.10
20 installed (along with 3.9 which is the default version on this machine
21 now).
23 Regards,
24 Arve


Subject Author
[gentoo-user] Re: How to diagnose version conflicts? Grant Edwards <grant.b.edwards@×××××.com>