Gentoo Archives: gentoo-user

From: Neil Bothwick <neil@××××××××××.uk>
To: gentoo-user@l.g.o
Subject: Re: [gentoo-user] getting blocks for system and world update not resolved
Date: Wed, 18 Mar 2015 08:48:13
Message-Id: 20150318084759.1cb783e9@digimed.co.uk
In Reply to: [gentoo-user] getting blocks for system and world update not resolved by Tamer Higazi
On Wed, 18 Mar 2015 05:11:25 +0100, Tamer Higazi wrote:

> Hi people! > I have problems getting these blocks at a system update solved... > > I executed: > emerge --backtrack=30 -fuDN @system @world > ... > ... > [blocks B ] <perl-core/ExtUtils-Install-1.670.0 > ("<perl-core/ExtUtils-Install-1.670.0" is blocking > virtual/perl-ExtUtils-Install-1.670.0) > [blocks B ] media-libs/libpostproc ("media-libs/libpostproc" is > blocking media-video/ffmpeg-1.2.6-r1) > [blocks B ] <perl-core/Parse-CPAN-Meta-1.441.400 > ("<perl-core/Parse-CPAN-Meta-1.441.400" is blocking > virtual/perl-Parse-CPAN-Meta-1.441.400) > [blocks B ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is > blocking media-video/libav-9.17, media-libs/libpostproc-10.20140517-r1) > [blocks B ] <perl-core/ExtUtils-Manifest-1.630.0 > ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking > virtual/perl-ExtUtils-Manifest-1.630.0-r1) > [blocks B ] <perl-core/version-0.990.900 > ("<perl-core/version-0.990.900" is blocking > virtual/perl-version-0.990.900-r1) > [blocks B ] <perl-core/CPAN-Meta-YAML-0.12.0 > ("<perl-core/CPAN-Meta-YAML-0.12.0" is blocking > virtual/perl-CPAN-Meta-YAML-0.12.0)
eselect news list Then read the item titled "ffmpeg/libav conflict management". The perl issue has been covered several times already, including once a few days ago. Remove all references to perl-core from your world file emerge --deselect y $(qlist -IC perl-core) -- Neil Bothwick The trouble with the world is that everybody in it is three drinks behind.