Gentoo Archives: gentoo-user

From: Jonathan Callen <jcallen@g.o>
To: gentoo-user@l.g.o
Subject: [gentoo-user] Re: blockage
Date: Sun, 22 Mar 2015 05:21:48
Message-Id: 550E5161.3070407@gentoo.org
In Reply to: [gentoo-user] blockage by lee
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

On 2015-03-21 23:24, lee wrote:
> Hi, > > when trying to update with 'emerge -j 8 -a --update --deep > --with-bdeps=y @world' after 'emerge --sync', I'm getting the > following message: > > > * Error: The above package list contains packages which cannot be * > installed at the same time on the same system. > > (sys-process/procps-3.3.9-r2:0/0::gentoo, installed) pulled in by > sys-process/procps required by @system > > (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, ebuild scheduled for > merge) pulled in by >> =sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] >> (>=sys-apps/util-linux-2.24.1-r3[abi_x86_64 > (-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed) > sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, > installed) sys-apps/util-linux required by > (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed) > sys-apps/util-linux[static-libs?] (sys-apps/util-linux) required by > (sys-fs/zfs-9999:0/0::gentoo, installed) >> =sys-apps/util-linux-2.20 required by >> (sys-fs/udev-216:0/0::gentoo, installed) >> =sys-apps/util-linux-2.16 required by >> (sys-fs/e2fsprogs-1.42.12:0/0::gentoo, installed) >> =sys-apps/util-linux-2.16 required by >> (dev-libs/apr-1.5.0-r2:1/1::gentoo, installed) > sys-apps/util-linux required by @system sys-apps/util-linux > required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed) > sys-apps/util-linux required by > (app-emulation/lxc-1.0.7:0/0::gentoo, installed) > > (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) > pulled in by >> =sys-apps/sysvinit-2.86-r6 required by >> (sys-apps/openrc-0.13.11:0/0::gentoo, installed) > <=sys-apps/sysvinit-2.88-r4 required by > (sys-power/apcupsd-3.14.8-r2:0/0::gentoo, installed) > > > I don't understand this message. What is blocked by what and why, > and what am I supposed to do? > >
- From what I can see, it appears that the problem may be that you need one of the following packages installed for sys-power/apcupsd: >=sys-apps/util-linux-2.23[tty-helpers] <=sys-apps/sysvinit-2.88-r4 You probably currently have an older version of sysvinit installed, which satisfies that dependency. Portage wants to upgrade you to the latest version of sysvinit, but you don't have a new-enough util-linux installed with USE=tty-helpers, and you didn't tell portage it was allowed to set that flag, so it doesn't know what you want to do about the issue. The easiest solution is probably to add "sys-apps/util-linux tty-helpers" to your /etc/portage/package.use. - -- Jonathan Callen -----BEGIN PGP SIGNATURE----- Version: GnuPG v2 iQIcBAEBCgAGBQJVDlFhAAoJEEIQbvYRB3mgvWQP/0mz5t2BHE/nIsLYUX8Yxhdo /bLrNM+WbArsHfTDMn7jmh/ynmvcZ0oeWDHd1zqgx8ICf+10wreZOlgkhhmLFrl1 ZYzDP5gmWyY6NtYfDOu8az59riTMJBGFkmStCp3jlpFjH7yaYipOHx04gt2Ccs55 ZHxEaojV1vgtJxX4W3Ed8sMIbsPyBZ0BrmV89pigedOu5IF5C1FnW+us4ETGmAsc RztPqv3oDUVvyvyco8yi21vrMYrLhI+uo5EDJ9/zGjJJ8xfIpBOFhp1HjDx5j6Q3 eKvCAjfaxuwp0E1vMEPp0vZxe7m8QWCQFtaErZvxOSUKuzq4+4JTBTlsS7JUs3Pt d4/cHXwrQY1Er2MtF7/alcFv6LH8QeXK1wK29v2cC7zDNmVyeIRzdp1OdgnukWMb huBzLgs3tQm1fGDL9mxOshaE+eHUPYgqvzpRUgVRIgNQ6tx1/vi6bb/OuR0hPHr6 TNJbXRlI6V6Iv+1vvBnZvy18ndVKnEL+D2x2KfkRuY5m9lQua+KU/fwAbUhV++k5 5LE6YUGEP2tLrUYzp65pMA2lo4Td+JzvG2H+yfFepn+6A8XMePXqaP6W4mDtdZC6 JgcfoMjLz0bUXUN5itLFthObMJZUhEoqnKs5wx/P8vKPUqhHW244GJSNz5/dUkEg 0n6twqA8q4JGSfakcEfe =I93s -----END PGP SIGNATURE-----

Replies

Subject Author
Re: [gentoo-user] Re: blockage lee <lee@××××××××.de>